summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2025-04-22 16:49:10 +0800
committerKhem Raj <raj.khem@gmail.com>2025-04-23 19:35:06 -0700
commita3bc118ed5430d61578ac2ad0164e44ae1ea93fc (patch)
treeb89318bd4bff947a810d02ce6eef616cadcece5d /meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
parent676d1ba1141869580503e02dc6b2d54a264acbc3 (diff)
downloadmeta-openembedded-a3bc118ed5430d61578ac2ad0164e44ae1ea93fc.tar.gz
python3-m2crypto: upgrade 0.44.0 -> 0.45.0
python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch refreshed for 0.45.0 Changelog: =========== - chore: build Windows builds with Python 3.13 as well - fix: remove support for Engine - chore: mark actual license of the project BSD-2-Clause instead of wrong MIT - ci(Debian): make M2Crypto buildable on Debian - swig: Workaround for reading sys/select.h ending with wrong types. - ci: bump required setuptools version because of change in naming strategy - fix: add fix for build with older GCC - fix: remove AnyStr and Any types - chore: add .git-blame-ignore-revs - chore: blacken everything Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
index 819ecabf6c..c4262985ba 100644
--- a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
+++ b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
@@ -1,4 +1,4 @@
1From b14664fdab286485c5cbc0fbe5b0ff13f062edd8 Mon Sep 17 00:00:00 2001 1From eaeb95ec64762a58dde7cf368fc17188382e7df6 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 28 Mar 2025 12:13:26 +0800 3Date: Fri, 28 Mar 2025 12:13:26 +0800
4Subject: [PATCH] setup.py: Make the cmd available 4Subject: [PATCH] setup.py: Make the cmd available
@@ -23,10 +23,10 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
23 1 file changed, 1 insertion(+), 1 deletion(-) 23 1 file changed, 1 insertion(+), 1 deletion(-)
24 24
25diff --git a/setup.py b/setup.py 25diff --git a/setup.py b/setup.py
26index 7e295f3..cc414c9 100644 26index 9938e67..21e2346 100644
27--- a/setup.py 27--- a/setup.py
28+++ b/setup.py 28+++ b/setup.py
29@@ -221,7 +221,7 @@ class _M2CryptoBuildExt(build_ext.build_ext): 29@@ -230,7 +230,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
30 with open( 30 with open(
31 "src/SWIG/x509_v_flag.h", "w", encoding="utf-8" 31 "src/SWIG/x509_v_flag.h", "w", encoding="utf-8"
32 ) as x509_v_h: 32 ) as x509_v_h:
@@ -35,6 +35,3 @@ index 7e295f3..cc414c9 100644
35 cflags = os.environ.get("CFLAGS") 35 cflags = os.environ.get("CFLAGS")
36 if cflags is not None: 36 if cflags is not None:
37 cmd += cflags.split() 37 cmd += cflags.split()
38--
392.34.1
40