summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-10-16 21:35:03 +0200
committerKhem Raj <raj.khem@gmail.com>2024-10-16 14:07:30 -0700
commit0b3f4ed292c4b494a83f912184ad284edc72c2e3 (patch)
tree26aecc1e1f69421d7bcccb73ed11fba736d23812 /meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
parent4a78fcff7cefb9bbf1d6223b5ad90af0f8e7ae14 (diff)
downloadmeta-openembedded-0b3f4ed292c4b494a83f912184ad284edc72c2e3.tar.gz
python3-m2crypto: update 0.40.1 -> 0.42.0
This addresses python 3.13 issues. Use build_meta instead of classic setuptools. Drop all setup.py patches as no longer necessary. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
deleted file mode 100644
index c67e50803b..0000000000
--- a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 0d824e5c2ab13e761ffaeabdccf9513d5b8f280d Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex@linutronix.de>
3Date: Fri, 8 Oct 2021 11:18:35 +0200
4Subject: [PATCH] setup.py: address openssl 3.x build issue
5
6swig throws:
7| /home/alex/development/poky/build-metaoe/tmp/work/x86_64-linux/python3-m2crypto-native/0.38.0-r0/recipe-sysroot-native/usr/include/openssl/macros.h:155: Error: CPP #error ""OPENSSL_API_COMPAT expresses an impossible API compatibility level"". Use the -cpperraswarn option to continue swig processing.
8
9I'm not sure why; upstream should take a look.
10
11Upstream-Status: Inappropriate [workaround]
12Signed-off-by: Alexander Kanavin <alex@linutronix.de>
13---
14 setup.py | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/setup.py b/setup.py
18index 2c65404..74704bc 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -192,6 +192,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
22
23 self.swig_opts.append('-includeall')
24 self.swig_opts.append('-modern')
25+ self.swig_opts.append('-cpperraswarn')
26 self.swig_opts.append('-builtin')
27
28 # These two lines are a workaround for