summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-10-16 21:35:03 +0200
committerKhem Raj <raj.khem@gmail.com>2024-10-16 14:07:30 -0700
commit0b3f4ed292c4b494a83f912184ad284edc72c2e3 (patch)
tree26aecc1e1f69421d7bcccb73ed11fba736d23812 /meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
parent4a78fcff7cefb9bbf1d6223b5ad90af0f8e7ae14 (diff)
downloadmeta-openembedded-0b3f4ed292c4b494a83f912184ad284edc72c2e3.tar.gz
python3-m2crypto: update 0.40.1 -> 0.42.0
This addresses python 3.13 issues. Use build_meta instead of classic setuptools. Drop all setup.py patches as no longer necessary. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
deleted file mode 100644
index 0baadfcaa5..0000000000
--- a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 29 Mar 2013 15:17:17 +0100
4Subject: [PATCH] setup.py: link in sysroot, not in host directories
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-Status: Pending [Unknown]
9---
10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-)
12
13--- a/setup.py
14+++ b/setup.py
15@@ -135,6 +135,7 @@ class _M2CryptoBuildExt(build_ext.build_
16 self.set_undefined_options('build', ('bundledlls', 'bundledlls'))
17
18 self.libraries = ['ssl', 'crypto']
19+ self.openssl = os.environ.get( "STAGING_DIR" )
20 if sys.platform == 'win32':
21 self.libraries = ['ssleay32', 'libeay32']
22 if self.openssl and openssl_version(self.openssl,
23@@ -159,8 +160,8 @@ class _M2CryptoBuildExt(build_ext.build_
24
25 if self.openssl is not None:
26 log.debug('self.openssl = %s', self.openssl)
27- openssl_library_dir = os.path.join(self.openssl, 'lib')
28- openssl_include_dir = os.path.join(self.openssl, 'include')
29+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
30+ openssl_include_dir = os.environ.get( "STAGING_INCDIR" )
31
32 self.library_dirs.append(openssl_library_dir)
33 self.include_dirs.append(openssl_include_dir)