diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2024-10-16 21:35:03 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-16 14:07:30 -0700 |
commit | 0b3f4ed292c4b494a83f912184ad284edc72c2e3 (patch) | |
tree | 26aecc1e1f69421d7bcccb73ed11fba736d23812 /meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | |
parent | 4a78fcff7cefb9bbf1d6223b5ad90af0f8e7ae14 (diff) | |
download | meta-openembedded-0b3f4ed292c4b494a83f912184ad284edc72c2e3.tar.gz |
python3-m2crypto: update 0.40.1 -> 0.42.0
This addresses python 3.13 issues.
Use build_meta instead of classic setuptools.
Drop all setup.py patches as no longer necessary.
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | 33 |
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch deleted file mode 100644 index 77ef7e557e..0000000000 --- a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | Do not compute platform, this does not work in cross compile environment | ||
2 | since it pokes at the system for getting architecture values | ||
3 | |||
4 | Upstream-Status: Inappropriate | ||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | |||
7 | --- a/setup.py | ||
8 | +++ b/setup.py | ||
9 | @@ -169,24 +169,6 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
10 | log.debug('self.include_dirs = %s', self.include_dirs) | ||
11 | log.debug('self.library_dirs = %s', self.library_dirs) | ||
12 | |||
13 | - if platform.system() == "Linux": | ||
14 | - # For RedHat-based distros, the '-D__{arch}__' option for | ||
15 | - # Swig needs to be normalized, particularly on i386. | ||
16 | - mach = platform.machine().lower() | ||
17 | - if mach in ('i386', 'i486', 'i586', 'i686'): | ||
18 | - arch = '__i386__' | ||
19 | - elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'): | ||
20 | - arch = '__powerpc64__' | ||
21 | - elif mach in ('ppc', 'powerpc'): | ||
22 | - arch = '__powerpc__' | ||
23 | - else: | ||
24 | - arch = '__%s__' % mach | ||
25 | - self.swig_opts.append('-D%s' % arch) | ||
26 | - if mach in ('ppc64le', 'ppc64el'): | ||
27 | - self.swig_opts.append('-D_CALL_ELF=2') | ||
28 | - if mach in ('arm64_be'): | ||
29 | - self.swig_opts.append('-D__AARCH64EB__') | ||
30 | - | ||
31 | self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) | ||
32 | |||
33 | # Some Linux distributor has added the following line in | ||