summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2024-12-16 15:55:14 +0000
committerKhem Raj <raj.khem@gmail.com>2024-12-19 09:41:21 -0800
commitc089690f57155cc62c3b22a9af9527ec927b16e3 (patch)
tree3616102cf6d352c02eef8601bf9f4cec31d1381d /meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
parentdd241e2406db26f08ec3507ce73b273a893378e2 (diff)
downloadmeta-openembedded-c089690f57155cc62c3b22a9af9527ec927b16e3.tar.gz
python3-*: Update recipes to correctly check the upstream packages
With the upstream check migrated to the simple repo API, a number of the recipes required updates to: 1. Remove outdated UPSTREAM_CHECK_REGEX checks 2. Add recipe specific UPSTREAM_CHECK_PYPI_PACKAGE definitions for packages that use '_', CamelCase, or other deviations from PEP625 in the source archive Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb b/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
index 335565643a..b7d5c8efc3 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
@@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d4692a0eb42ca54892399db2cb35e61e"
6SRC_URI[sha256sum] = "8423b23ec666be3d16e16b60bdd8ac4e86e840ebd1dd11a30b9f117f2fa0ab90" 6SRC_URI[sha256sum] = "8423b23ec666be3d16e16b60bdd8ac4e86e840ebd1dd11a30b9f117f2fa0ab90"
7 7
8PYPI_PACKAGE = "matplotlib_inline" 8PYPI_PACKAGE = "matplotlib_inline"
9UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
10
9inherit pypi python_setuptools_build_meta 11inherit pypi python_setuptools_build_meta
10 12
11RDEPENDS:${PN} = "python3-traitlets" 13RDEPENDS:${PN} = "python3-traitlets"