summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2024-08-08 08:46:56 -0400
committerKhem Raj <raj.khem@gmail.com>2024-08-09 14:25:26 -0700
commitd646925e6ded7417cd76bc931d3b55f7516bae8b (patch)
tree4f38ea6d8c5dbd273fc2875889eca3af5aba1f2c /meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
parent90f96e053ad3eefa7693d9748efdfbfa72d7dcfd (diff)
downloadmeta-openembedded-d646925e6ded7417cd76bc931d3b55f7516bae8b.tar.gz
python3-matplotlib-inline: update 0.1.6 → 0.1.7 plus fixes
Update to the latest upstream released version. Add a PYPI_PACKAGE entry to the recipe. Otherwise, during final image assembly, an error similar to the following would occur due to the fact the yocto package name (which includes dashes) differs from the download filename (which includes underscores). NOTE: this would happen with all package types, not just ipk: ERROR: core-image-base-1.0-r0 do_rootfs: Unable to install packages. Command '/scratch/trevor/oe/builds/jupyter/jupyter-rockchip/scarthgap/build/tmp-glibc/work/rock_5a-oe-linux/core-image-base/1.0/recipe-sysroot-native/usr/bin/opkg --volatile-cache -f /scratch/trevor/oe/builds/jupyter/jupyter-rockchip/scarthgap/build/tmp-glibc/work/rock_5a-oe-linux/core-image-base/1.0/opkg.conf -t /scratch/trevor/oe/builds/jupyter/jupyter-rockchip/scarthgap/build/tmp-glibc/work/rock_5a-oe-linux/core-image-base/1.0/temp/ipktemp/ -o /scratch/trevor/oe/builds/jupyter/jupyter-rockchip/scarthgap/build/tmp-glibc/work/rock_5a-oe-linux/core-image-base/1.0/rootfs --force_postinstall --prefer-arch-to-version <package list including python3-matplotlib-inline...> returned 255: * opkg_solver_install: No candidates to install python3-matplotlib-inline (null)! Add additional devtool-discovered information: - update the build mechanism to include python_setuptools_build_meta - add the RDEPENDS Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb b/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
new file mode 100644
index 0000000000..335565643a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-matplotlib-inline_0.1.7.bb
@@ -0,0 +1,11 @@
1SUMMARY = "Inline Matplotlib backend for Jupyter"
2HOMEPAGE = "https://pypi.org/project/matplotlib-inline/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d4692a0eb42ca54892399db2cb35e61e"
5
6SRC_URI[sha256sum] = "8423b23ec666be3d16e16b60bdd8ac4e86e840ebd1dd11a30b9f117f2fa0ab90"
7
8PYPI_PACKAGE = "matplotlib_inline"
9inherit pypi python_setuptools_build_meta
10
11RDEPENDS:${PN} = "python3-traitlets"