diff options
author | Trevor Gamblin <tgamblin@baylibre.com> | 2023-07-25 15:09:40 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-25 12:46:19 -0700 |
commit | 3a63fbf62a72cbfb407f776f673ca34e43f08b9a (patch) | |
tree | 4bff432a5e7042eab1b18fcc5771a4fb02be6de8 /meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch | |
parent | fe48529f1c763ffaea6835837da41421c9a18ee1 (diff) | |
download | meta-openembedded-3a63fbf62a72cbfb407f776f673ca34e43f08b9a.tar.gz |
python3-matplotlib: upgrade 3.6.3 -> 3.7.2
- Adjust target lines in setup.py for LIC_FILES_CHKSUM, since the
content of interest has moved (but not changed)
- Tweak matplotlib-disable-download.patch to apply on 3.7.2
- Remove backported patch since it's in 3.7.2:
[tgamblin@megalith matplotlib]$ git log --oneline --grep="removed RandomNumberGenerator class"
601d92a885 removed RandomNumberGenerator class, included <random>, replaced random_shuffle with shuffle and used mersenne twister engine to generate uniform random bit generator for the shuffle.
[tgamblin@megalith matplotlib]$ git tag --contains 601d92a885
v3.7.0
v3.7.0rc1
v3.7.1
v3.7.2
Changelog: https://github.com/matplotlib/matplotlib/releases
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch | 59 |
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch b/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch deleted file mode 100644 index 1f9b8cdeaf..0000000000 --- a/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | From 3eb9987b02cc10b93e09219ddc86aa6be5f10177 Mon Sep 17 00:00:00 2001 | ||
2 | From: tybeller <ty.c.beller@gmail.com> | ||
3 | Date: Fri, 30 Sep 2022 16:13:41 -0400 | ||
4 | Subject: [PATCH] removed RandomNumberGenerator class, included <random>, | ||
5 | replaced random_shuffle with shuffle and used mersenne twister engine to | ||
6 | generate uniform random bit generator for the shuffle. | ||
7 | |||
8 | Upstream-Status: Backport [https://github.com/matplotlib/matplotlib/commit/601d92a8850] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/tri/_tri.cpp | 20 ++++---------------- | ||
12 | 1 file changed, 4 insertions(+), 16 deletions(-) | ||
13 | |||
14 | diff --git a/src/tri/_tri.cpp b/src/tri/_tri.cpp | ||
15 | index b7a87783de..6e639eea44 100644 | ||
16 | --- a/src/tri/_tri.cpp | ||
17 | +++ b/src/tri/_tri.cpp | ||
18 | @@ -12,6 +12,7 @@ | ||
19 | |||
20 | #include <algorithm> | ||
21 | #include <set> | ||
22 | +#include <random> | ||
23 | |||
24 | |||
25 | TriEdge::TriEdge() | ||
26 | @@ -1465,8 +1466,8 @@ TrapezoidMapTriFinder::initialize() | ||
27 | _tree->assert_valid(false); | ||
28 | |||
29 | // Randomly shuffle all edges other than first 2. | ||
30 | - RandomNumberGenerator rng(1234); | ||
31 | - std::random_shuffle(_edges.begin()+2, _edges.end(), rng); | ||
32 | + std::mt19937 rng(1234); | ||
33 | + std::shuffle(_edges.begin()+2, _edges.end(), rng); | ||
34 | |||
35 | // Add edges, one at a time, to tree. | ||
36 | size_t nedges = _edges.size(); | ||
37 | @@ -2055,17 +2056,4 @@ TrapezoidMapTriFinder::Trapezoid::set_upper_right(Trapezoid* upper_right_) | ||
38 | upper_right = upper_right_; | ||
39 | if (upper_right != 0) | ||
40 | upper_right->upper_left = this; | ||
41 | -} | ||
42 | - | ||
43 | - | ||
44 | - | ||
45 | -RandomNumberGenerator::RandomNumberGenerator(unsigned long seed) | ||
46 | - : _m(21870), _a(1291), _c(4621), _seed(seed % _m) | ||
47 | -{} | ||
48 | - | ||
49 | -unsigned long | ||
50 | -RandomNumberGenerator::operator()(unsigned long max_value) | ||
51 | -{ | ||
52 | - _seed = (_seed*_a + _c) % _m; | ||
53 | - return (_seed*max_value) / _m; | ||
54 | -} | ||
55 | +} | ||
56 | \ No newline at end of file | ||
57 | -- | ||
58 | 2.39.0 | ||
59 | |||