summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-16 20:24:09 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-16 21:23:07 -0800
commit1f56bcddaf5bb6d7c8a9a7a3e3dc3b83fc6aa051 (patch)
tree705268a79044911749875756596776115d11bb65 /meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
parent9b6baed24d5efe0820266ccf3567bcff42701a01 (diff)
downloadmeta-openembedded-1f56bcddaf5bb6d7c8a9a7a3e3dc3b83fc6aa051.tar.gz
python3-matplotlib: Upgrade to 3.6.3
Forward port the disable download patch Location of license changed inside setup.py Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch26
1 files changed, 20 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index 25c49afb97..899cac624a 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -6,18 +6,32 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
6 6
7--- a/setup.py 7--- a/setup.py
8+++ b/setup.py 8+++ b/setup.py
9@@ -316,8 +316,6 @@ setup( # Finally, pass this all along t 9@@ -303,7 +303,6 @@ setup( # Finally, pass this all along t
10 setup_requires=[ 10 setup_requires=[
11 "certifi>=2020.06.20", 11 "certifi>=2020.06.20",
12 "numpy>=1.17", 12 "numpy>=1.19",
13- "setuptools_scm>=4,<7", 13- "setuptools_scm>=7",
14- "setuptools_scm_git_archive",
15 ], 14 ],
16 install_requires=[ 15 install_requires=[
17 "cycler>=0.10", 16 "contourpy>=1.0.1",
17@@ -315,13 +314,7 @@ setup( # Finally, pass this all along t
18 "pillow>=6.2.0",
19 "pyparsing>=2.2.1",
20 "python-dateutil>=2.7",
21- ] + (
22- # Installing from a git checkout that is not producing a wheel.
23- ["setuptools_scm>=7"] if (
24- Path(__file__).with_name(".git").exists() and
25- os.environ.get("CIBUILDWHEEL", "0") != "1"
26- ) else []
27- ),
28+ ],
29 use_scm_version={
30 "version_scheme": "release-branch-semver",
31 "local_scheme": "node-and-date",
18--- a/setupext.py 32--- a/setupext.py
19+++ b/setupext.py 33+++ b/setupext.py
20@@ -64,40 +64,7 @@ def get_from_cache_or_download(url, sha) 34@@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha)
21 BytesIO 35 BytesIO
22 The file loaded into memory. 36 The file loaded into memory.
23 """ 37 """