diff options
author | Trevor Gamblin <tgamblin@baylibre.com> | 2023-07-25 15:09:40 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-25 12:46:19 -0700 |
commit | 3a63fbf62a72cbfb407f776f673ca34e43f08b9a (patch) | |
tree | 4bff432a5e7042eab1b18fcc5771a4fb02be6de8 /meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | |
parent | fe48529f1c763ffaea6835837da41421c9a18ee1 (diff) | |
download | meta-openembedded-3a63fbf62a72cbfb407f776f673ca34e43f08b9a.tar.gz |
python3-matplotlib: upgrade 3.6.3 -> 3.7.2
- Adjust target lines in setup.py for LIC_FILES_CHKSUM, since the
content of interest has moved (but not changed)
- Tweak matplotlib-disable-download.patch to apply on 3.7.2
- Remove backported patch since it's in 3.7.2:
[tgamblin@megalith matplotlib]$ git log --oneline --grep="removed RandomNumberGenerator class"
601d92a885 removed RandomNumberGenerator class, included <random>, replaced random_shuffle with shuffle and used mersenne twister engine to generate uniform random bit generator for the shuffle.
[tgamblin@megalith matplotlib]$ git tag --contains 601d92a885
v3.7.0
v3.7.0rc1
v3.7.1
v3.7.2
Changelog: https://github.com/matplotlib/matplotlib/releases
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | 28 |
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch index 899cac624a..aea8f62ea7 100644 --- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch +++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | |||
@@ -4,19 +4,17 @@ Upstream-Status: Inappropriate [disable feature] | |||
4 | 4 | ||
5 | Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> | 5 | Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> |
6 | 6 | ||
7 | Update patch to fit on 3.7.2. | ||
8 | |||
9 | Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> | ||
10 | |||
11 | diff --git a/setup.py b/setup.py | ||
12 | index 0bea13fa6f..f39d8fc871 100644 | ||
7 | --- a/setup.py | 13 | --- a/setup.py |
8 | +++ b/setup.py | 14 | +++ b/setup.py |
9 | @@ -303,7 +303,6 @@ setup( # Finally, pass this all along t | 15 | @@ -327,13 +327,7 @@ setup( # Finally, pass this all along to setuptools to do the heavy lifting. |
10 | setup_requires=[ | ||
11 | "certifi>=2020.06.20", | ||
12 | "numpy>=1.19", | ||
13 | - "setuptools_scm>=7", | ||
14 | ], | ||
15 | install_requires=[ | ||
16 | "contourpy>=1.0.1", | ||
17 | @@ -315,13 +314,7 @@ setup( # Finally, pass this all along t | ||
18 | "pillow>=6.2.0", | 16 | "pillow>=6.2.0", |
19 | "pyparsing>=2.2.1", | 17 | "pyparsing>=2.3.1,<3.1", |
20 | "python-dateutil>=2.7", | 18 | "python-dateutil>=2.7", |
21 | - ] + ( | 19 | - ] + ( |
22 | - # Installing from a git checkout that is not producing a wheel. | 20 | - # Installing from a git checkout that is not producing a wheel. |
@@ -26,12 +24,14 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> | |||
26 | - ) else [] | 24 | - ) else [] |
27 | - ), | 25 | - ), |
28 | + ], | 26 | + ], |
29 | use_scm_version={ | 27 | extras_require={ |
30 | "version_scheme": "release-branch-semver", | 28 | ':python_version<"3.10"': [ |
31 | "local_scheme": "node-and-date", | 29 | "importlib-resources>=3.2.0", |
30 | diff --git a/setupext.py b/setupext.py | ||
31 | index a898d642d6..474172ff8f 100644 | ||
32 | --- a/setupext.py | 32 | --- a/setupext.py |
33 | +++ b/setupext.py | 33 | +++ b/setupext.py |
34 | @@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha) | 34 | @@ -66,40 +66,7 @@ def get_from_cache_or_download(url, sha): |
35 | BytesIO | 35 | BytesIO |
36 | The file loaded into memory. | 36 | The file loaded into memory. |
37 | """ | 37 | """ |