diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-01-11 12:18:12 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-18 08:59:58 -0800 |
commit | d323e21f1a3b9ae6d5b38e14efb6c4e72fb4992c (patch) | |
tree | 22da6ce2151aa91b6f62248465bc720e022dc0c6 /meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | |
parent | 6d5426249728daef3a92d8c67c60d6b2100fba05 (diff) | |
download | meta-openembedded-d323e21f1a3b9ae6d5b38e14efb6c4e72fb4992c.tar.gz |
python3-matplotlib: Do not use setuptools_scm_git_archive
this gets invoked during compile task which is not disabling network
access, any network activity should be explicitly enabled except during
do_fetch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | 20 |
1 files changed, 15 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch index e032ceb2c9..42ffeb8970 100644 --- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch +++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | |||
@@ -4,9 +4,19 @@ Upstream-Status: Inappropriate [disable feature] | |||
4 | 4 | ||
5 | Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> | 5 | Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> |
6 | 6 | ||
7 | --- a/setupext.py.orig 2021-12-14 09:44:33.499041044 -0800 | 7 | --- a/setup.py |
8 | +++ a/setupext.py 2021-12-14 09:45:00.447041706 -0800 | 8 | +++ b/setup.py |
9 | @@ -64,40 +64,7 @@ | 9 | @@ -317,7 +317,6 @@ setup( # Finally, pass this all along t |
10 | "certifi>=2020.06.20", | ||
11 | "numpy>=1.17", | ||
12 | "setuptools_scm>=4", | ||
13 | - "setuptools_scm_git_archive", | ||
14 | ], | ||
15 | install_requires=[ | ||
16 | "cycler>=0.10", | ||
17 | --- a/setupext.py | ||
18 | +++ b/setupext.py | ||
19 | @@ -64,40 +64,7 @@ def get_from_cache_or_download(url, sha) | ||
10 | BytesIO | 20 | BytesIO |
11 | The file loaded into memory. | 21 | The file loaded into memory. |
12 | """ | 22 | """ |
@@ -45,6 +55,6 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> | |||
45 | - | 55 | - |
46 | - return BytesIO(data) | 56 | - return BytesIO(data) |
47 | + raise IOError(f"Automatic downloading is disabled.") | 57 | + raise IOError(f"Automatic downloading is disabled.") |
48 | 58 | ||
49 | 59 | ||
50 | def get_and_extract_tarball(urls, sha, dirname): | 60 | def get_and_extract_tarball(urls, sha, dirname): |