summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-12-14 13:04:36 -0600
committerKhem Raj <raj.khem@gmail.com>2021-12-16 08:14:04 -0800
commitc46b44f1e8ac0364aebac919ee2b907149c0411c (patch)
treeedccfa738871737fd2a56da2ea67b7c86bfcbba1 /meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
parenta221d0cbc569702a79bc7814fcc2102770ee2653 (diff)
downloadmeta-openembedded-c46b44f1e8ac0364aebac919ee2b907149c0411c.tar.gz
python3-matplotlib: Disable automatic download during do_compile
Add a patch to disable the automatic download of components. Add manual download for a specific freetype and qhull version. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
index f8448d5f1d..84bec0b201 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
@@ -25,6 +25,18 @@ SRC_URI[sha256sum] = "b2e9810e09c3a47b73ce9cab5a72243a1258f61e7900969097a8172322
25 25
26inherit pypi setuptools3 pkgconfig 26inherit pypi setuptools3 pkgconfig
27 27
28# Stop the component from attempting to download when it detects a missing
29# dependency
30SRC_URI += "file://matplotlib-disable-download.patch"
31
32# This python module requires a full copy of freetype-2.6.1
33SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build"
34SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014"
35
36# This python module requires a full copy of 'qhull-2020'
37SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build"
38SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e"
39
28# LTO with clang needs lld 40# LTO with clang needs lld
29LDFLAGS:append:toolchain-clang = " -fuse-ld=lld" 41LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
30LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld" 42LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld"