diff options
author | Trevor Gamblin <tgamblin@baylibre.com> | 2023-07-25 15:09:40 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-25 12:46:19 -0700 |
commit | 3a63fbf62a72cbfb407f776f673ca34e43f08b9a (patch) | |
tree | 4bff432a5e7042eab1b18fcc5771a4fb02be6de8 /meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb | |
parent | fe48529f1c763ffaea6835837da41421c9a18ee1 (diff) | |
download | meta-openembedded-3a63fbf62a72cbfb407f776f673ca34e43f08b9a.tar.gz |
python3-matplotlib: upgrade 3.6.3 -> 3.7.2
- Adjust target lines in setup.py for LIC_FILES_CHKSUM, since the
content of interest has moved (but not changed)
- Tweak matplotlib-disable-download.patch to apply on 3.7.2
- Remove backported patch since it's in 3.7.2:
[tgamblin@megalith matplotlib]$ git log --oneline --grep="removed RandomNumberGenerator class"
601d92a885 removed RandomNumberGenerator class, included <random>, replaced random_shuffle with shuffle and used mersenne twister engine to generate uniform random bit generator for the shuffle.
[tgamblin@megalith matplotlib]$ git tag --contains 601d92a885
v3.7.0
v3.7.0rc1
v3.7.1
v3.7.2
Changelog: https://github.com/matplotlib/matplotlib/releases
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb | 70 |
1 files changed, 70 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb new file mode 100644 index 0000000000..72c369100a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb | |||
@@ -0,0 +1,70 @@ | |||
1 | SUMMARY = "matplotlib: plotting with Python" | ||
2 | DESCRIPTION = "\ | ||
3 | Matplotlib is a Python 2D plotting library which produces \ | ||
4 | publication-quality figures in a variety of hardcopy formats \ | ||
5 | and interactive environments across platforms." | ||
6 | HOMEPAGE = "https://github.com/matplotlib/matplotlib" | ||
7 | SECTION = "devel/python" | ||
8 | LICENSE = "PSF-2.0" | ||
9 | LIC_FILES_CHKSUM = "\ | ||
10 | file://setup.py;beginline=293;endline=293;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \ | ||
11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ | ||
12 | " | ||
13 | |||
14 | DEPENDS = "\ | ||
15 | freetype \ | ||
16 | libpng \ | ||
17 | python3-numpy-native \ | ||
18 | python3-pip-native \ | ||
19 | python3-dateutil-native \ | ||
20 | python3-pytz-native \ | ||
21 | python3-certifi-native \ | ||
22 | python3-setuptools-scm-native \ | ||
23 | python3-pybind11-native \ | ||
24 | " | ||
25 | SRC_URI[sha256sum] = "a8cdb91dddb04436bd2f098b8fdf4b81352e68cf4d2c6756fcc414791076569b" | ||
26 | |||
27 | inherit pypi setuptools3 pkgconfig | ||
28 | |||
29 | # Stop the component from attempting to download when it detects a missing | ||
30 | # dependency | ||
31 | SRC_URI += "file://matplotlib-disable-download.patch \ | ||
32 | " | ||
33 | |||
34 | # This python module requires a full copy of freetype-2.6.1 | ||
35 | SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build" | ||
36 | SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014" | ||
37 | |||
38 | # This python module requires a full copy of 'qhull-2020' | ||
39 | SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build" | ||
40 | SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e" | ||
41 | |||
42 | # LTO with clang needs lld | ||
43 | LDFLAGS:append:toolchain-clang = " -fuse-ld=lld" | ||
44 | LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld" | ||
45 | LDFLAGS:remove:toolchain-clang:riscv64 = "-fuse-ld=lld" | ||
46 | LDFLAGS:remove:toolchain-clang:riscv32 = "-fuse-ld=lld" | ||
47 | RDEPENDS:${PN} = "\ | ||
48 | freetype \ | ||
49 | libpng \ | ||
50 | python3-numpy \ | ||
51 | python3-pyparsing \ | ||
52 | python3-cycler \ | ||
53 | python3-dateutil \ | ||
54 | python3-kiwisolver \ | ||
55 | python3-pytz \ | ||
56 | python3-pillow \ | ||
57 | python3-packaging \ | ||
58 | " | ||
59 | |||
60 | ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/mplsetup.cfg" | ||
61 | ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/mplsetup.cfg" | ||
62 | ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/mplsetup.cfg" | ||
63 | |||
64 | do_compile:prepend() { | ||
65 | echo [libs] > ${S}/mplsetup.cfg | ||
66 | echo system_freetype = True >> ${S}/mplsetup.cfg | ||
67 | ${ENABLELTO} | ||
68 | } | ||
69 | |||
70 | BBCLASSEXTEND = "native" | ||