summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-23 12:51:30 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-25 10:21:16 -0700
commit2fc0494071d57a00d808fc734b6dcbc35acdf16a (patch)
tree530be6cc9b8a91a47c434299f2746d7d5ca564e1 /meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb
parent242b4c1eca5c4ef352bba2e8c9605532e380fe16 (diff)
downloadmeta-openembedded-2fc0494071d57a00d808fc734b6dcbc35acdf16a.tar.gz
python3-more-itertools: Upgrade 8.3.0 -> 8.4.0
Upgrade to release 8.4.0: - New itertools: :func:`mark_ends` :func:`is_sorted` - Changes to existing itertools: :func:`islice_extended` can now be used with real slices The implementations for :func:`filter_except` and :func:`map_except` were improved - Other changes: Automated tests now enforce code style (using black) The various signatures of :func:`islice_extended` and :func:`numeric_range` now appear in the docs The test configuration for mypy was updated Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb b/meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb
new file mode 100644
index 0000000000..f040b1a97d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-more-itertools_8.4.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "More routines for operating on iterables, beyond itertools"
2HOMEPAGE = "https://github.com/erikrose/more-itertools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
5
6SRC_URI[md5sum] = "0912041c05148ed079984cff69af2e99"
7SRC_URI[sha256sum] = "68c70cc7167bdf5c7c9d8f6954a7837089c6a36bf565383919bb595efb8a17e5"
8
9inherit pypi setuptools3 ptest
10
11BBCLASSEXTEND = "native nativesdk"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}