summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2024-08-12 14:20:36 -0400
committerKhem Raj <raj.khem@gmail.com>2024-08-23 22:35:11 -0700
commitd135ee1c0b4feaee338f476be9319759cd6feb94 (patch)
treefa41bdb0f2ac814bf26a3df8c2d489bf542284e1 /meta-python/recipes-devtools/python/python3-pandas
parentb0c91cdc2e1867545b566f8975ebad1d464187d1 (diff)
downloadmeta-openembedded-d135ee1c0b4feaee338f476be9319759cd6feb94.tar.gz
python3-pandas: upgrade 2.0.3 -> 2.2.2
pandas 2.2.2 is the first version compatible with numpy 2.0.x. The package now uses meson as the build backend, so change the recipe to inherit that. Its pyproject.toml pins required versions for Cython and meson, but newer upstream pandas releases are using different versions and compatibility strings, so just add an OE-specific patch to relax the requirements a bit for us. Changelog: https://pandas.pydata.org/pandas-docs/version/2.2.2/whatsnew/v2.2.2.html Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch
new file mode 100644
index 0000000000..f60f43a5b0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch
@@ -0,0 +1,37 @@
1From d46b8720a6bccb345f6bdd7ee2f5c357e7eb227b Mon Sep 17 00:00:00 2001
2From: Trevor Gamblin <tgamblin@baylibre.com>
3Date: Mon, 12 Aug 2024 11:27:36 -0400
4Subject: [PATCH] pyproject.toml: don't pin dependency versions
5
6Pandas will fail to build if the exact versions aren't found, but newer
7ones actually work. Since newer versions of pandas are adjusting the
8requires section of pyproject toml further, just patch it for us.
9
10Upstream-Status: Inappropriate [OE-Specific]
11
12Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
13---
14 pyproject.toml | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/pyproject.toml b/pyproject.toml
18index db9f055799..5158d60f59 100644
19--- a/pyproject.toml
20+++ b/pyproject.toml
21@@ -2,10 +2,10 @@
22 # Minimum requirements for the build system to execute.
23 # See https://github.com/scipy/scipy/pull/12940 for the AIX issue.
24 requires = [
25- "meson-python==0.13.1",
26- "meson==1.2.1",
27+ "meson-python>=0.13.1",
28+ "meson>=1.2.1",
29 "wheel",
30- "Cython==3.0.5", # Note: sync with setup.py, environment.yml and asv.conf.json
31+ "Cython>=3.0.5", # Note: sync with setup.py, environment.yml and asv.conf.json
32 # Force numpy higher than 2.0rc1, so that built wheels are compatible
33 # with both numpy 1 and 2
34 "numpy>=2.0.0rc1",
35--
362.39.2
37