summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-01-06 17:52:23 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-06 12:34:12 -0800
commit72ce0145e92a075385ae0d0965a418ffbd35cdb8 (patch)
tree4ca00f410b477b828ee916524ec063456c319e36 /meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
parentb8046c597538605eae132897a6795641cd170310 (diff)
downloadmeta-openembedded-72ce0145e92a075385ae0d0965a418ffbd35cdb8.tar.gz
python3-pandas: upgrade 1.3.4 -> 1.3.5
changelog: =============================================================================== -Fixed regression in Series.equals() when comparing floats with dtype object to None (GH44190) -Fixed regression in merge_asof() raising error when array was supplied as join key (GH42844) -Fixed regression when resampling DataFrame with DateTimeIndex with empty groups and uint8, uint16 or uint32 columns incorrectly raising RuntimeError (GH43329) -Fixed regression in creating a DataFrame from a timezone-aware Timestamp scalar near a Daylight Savings Time transition (GH42505) -Fixed performance regression in read_csv() (GH44106) -Fixed regression in Series.duplicated() and Series.drop_duplicates() when Series has Categorical dtype with boolean categories (GH44351) -Fixed regression in GroupBy.sum() with timedelta64[ns] dtype containing NaT failing to treat that value as NA (GH42659) -Fixed regression in RollingGroupby.cov() and RollingGroupby.corr() when other had the same shape as each group would incorrectly return superfluous groups in the result (GH42915) Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
new file mode 100644
index 0000000000..2547875395
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
@@ -0,0 +1,26 @@
1SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
8
9SRC_URI[sha256sum] = "1e4285f5de1012de20ca46b188ccf33521bff61ba5c5ebd78b4fb28e5416a9f1"
10
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"