summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2025-05-05 09:07:56 +0200
committerKhem Raj <raj.khem@gmail.com>2025-05-05 10:16:54 -0700
commit14fa41b559b1d4e4185094ab38494c0f2010f297 (patch)
tree5dc0337a54e6a6ad2a9a6e0821bd35fd7addd719 /meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch
parent5db1cb3137ec88f6a166b6d1315eb897f602208b (diff)
downloadmeta-openembedded-14fa41b559b1d4e4185094ab38494c0f2010f297.tar.gz
python3-posix-ipc: improve build_support
* fixes: https://lists.openembedded.org/g/openembedded-devel/message/117255 DEBUG: Executing shell function do_compile * Getting build dependencies for wheel... /usr/lib/ld-linux-aarch64.so.1: No such file or directory Traceback (most recent call last): File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/pyproject_hooks/_in_process/_in_process.py", line 389, in <module> main() ~~~~^^ File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/pyproject_hooks/_in_process/_in_process.py", line 373, in main json_out["return_val"] = hook(**hook_input["kwargs"]) ~~~~^^^^^^^^^^^^^^^^^^^^^^^^ File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/pyproject_hooks/_in_process/_in_process.py", line 143, in get_requires_for_build_wheel return hook(config_settings) File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/setuptools/build_meta.py", line 334, in get_requires_for_build_wheel return self._get_build_requires(config_settings, requirements=[]) ~~~~~~~~~~~~~~~~~~~~~~~~^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/setuptools/build_meta.py", line 304, in _get_build_requires self.run_setup() ~~~~~~~~~~~~~~^^ File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/recipe-sysroot-native/usr/lib/python3.13/site-packages/setuptools/build_meta.py", line 320, in run_setup exec(code, locals()) ~~~~^^^^^^^^^^^^^^^^ File "<string>", line 23, in <module> File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/posix_ipc-1.2.0/build_support/discover_system_info.py", line 409, in discover d["QUEUE_PRIORITY_MAX"] = sniff_mq_prio_max() ~~~~~~~~~~~~~~~~~^^ File "TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/posix_ipc-1.2.0/build_support/discover_system_info.py", line 238, in sniff_mq_prio_max if max_priority < 0: ^^^^^^^^^^^^^^^^ TypeError: '<' not supported between instances of 'str' and 'int' ERROR Backend subprocess exited when trying to invoke get_requires_for_build_wheel WARNING: TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/temp/run.do_compile.2736023:168 exit 1 from 'nativepython3 -m build --no-isolation --wheel --outdir TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/dist TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/python3-posix-ipc/1.2.0/posix_ipc-1.2.0' WARNING: Backtrace (BB generated script): On some hosts. Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch b/meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch
new file mode 100644
index 0000000000..8bb7267086
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-posix-ipc/0001-build_support-use-source-filename-instead-of-foo-for.patch
@@ -0,0 +1,50 @@
1From 09cfcf7de2aab873a13949d5a128ccfb9e54732d Mon Sep 17 00:00:00 2001
2From: Martin Jansa <martin.jansa@gmail.com>
3Date: Mon, 5 May 2025 08:15:37 +0200
4Subject: [PATCH] build_support: use source filename instead of 'foo' for
5 discover tests
6
7* helps when debugging the issues
8* use the same order of CC arguments in compile_and_run and
9 does_build_succeed just for consistency
10* use pthread in both compile_and_run and does_build_succeed functions
11 it was added only to does_build_succeed in 5ec39f7af8cfd8525d225b1302fa93f7133b3849
12 not sure if it was intentional
13
14Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
15Upstream-Status: Submitted [https://github.com/osvenskan/posix_ipc/pull/77]
16---
17 build_support/discover_system_info.py | 6 +++---
18 1 file changed, 3 insertions(+), 3 deletions(-)
19
20diff --git a/build_support/discover_system_info.py b/build_support/discover_system_info.py
21index bc4d174..6d059d9 100644
22--- a/build_support/discover_system_info.py
23+++ b/build_support/discover_system_info.py
24@@ -60,7 +60,7 @@ def does_build_succeed(filename, linker_options=""):
25 # Rather than testing whether or not it's needed, I just specify it
26 # everywhere since it's harmless to specify it when it's not needed.
27 cc = os.getenv("CC", "cc")
28- cmd = "%s -Wall -o ./build_support/src/foo ./build_support/src/%s %s -lpthread" % (cc, filename, linker_options)
29+ cmd = "%s -Wall -o ./build_support/src/%s ./build_support/src/%s %s -lpthread" % (cc, filename[:-2], filename, linker_options)
30
31 p = subprocess.Popen(cmd, shell=True, stdout=STDOUT, stderr=STDERR)
32
33@@ -73,7 +73,7 @@ def compile_and_run(filename, linker_options=""):
34 # Utility function that returns the stdout output from running the
35 # compiled source file; None if the compile fails.
36 cc = os.getenv("CC", "cc")
37- cmd = "%s -Wall -o ./build_support/src/foo %s ./build_support/src/%s" % (cc, linker_options, filename)
38+ cmd = "%s -Wall -o ./build_support/src/%s ./build_support/src/%s %s -lpthread" % (cc, filename[:-2], filename, linker_options)
39
40 p = subprocess.Popen(cmd, shell=True, stdout=STDOUT, stderr=STDERR)
41
42@@ -82,7 +82,7 @@ def compile_and_run(filename, linker_options=""):
43 return None
44
45 try:
46- s = subprocess.Popen(["./build_support/src/foo"],
47+ s = subprocess.Popen(["./build_support/src/%s" % filename[:-2]],
48 stdout=subprocess.PIPE).communicate()[0]
49 return s.strip().decode()
50 except Exception: