summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-13 11:59:13 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-16 23:11:58 -0700
commit53018fc6fec2a5e42b04cf062b705e4d19a96cfd (patch)
treedfd93cde6a444eaa1e94bdf82776bb077482b4af /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
parent6dfa4c5a4bdcd4f6dcc0bfb8a787841e02afd987 (diff)
downloadmeta-openembedded-53018fc6fec2a5e42b04cf062b705e4d19a96cfd.tar.gz
python3-prompt-toolkit: Upgrade 3.0.7 -> 3.0.8
Upgrade to release 3.0.8: - Added `validator` parameter to `input_dialog`. - Cope with stdout not having a working `fileno`. - Handle situation when /dev/null is piped into stdin, or when stdin is closed somehow. - Fix for telnet/ssh server: `isatty` method was not implemented. - Display correct error when a tuple is passed into `to_formatted_text`. - Pass along WORD parameter in `Document._is_word_before_cursor_complete`. Fixes some key bindings. - Expose `ProgressBarCounter` in shortcuts module. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
new file mode 100644
index 0000000000..0debba48d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
6SRC_URI[md5sum] = "cf3ca19873fa9e7f6162296cf6bae419"
7SRC_URI[sha256sum] = "25c95d2ac813909f813c93fde734b6e44406d1477a9faef7c915ff37d39c0a8c"
8
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "prompt_toolkit"
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-terminal \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-wcwidth \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-shell \
21 ${PYTHON_PN}-image \
22"
23
24BBCLASSEXTEND = "native nativesdk"