summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-26 19:59:25 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-27 08:54:40 -0700
commit917c57797504e41f91d8f57417f142ca05f87d65 (patch)
tree92fd0efd92d2b783c99869568d180c55f11bade1 /meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch
parent769d79278403a193bdc4fbb68c9e21aab6cb71d1 (diff)
downloadmeta-openembedded-917c57797504e41f91d8f57417f142ca05f87d65.tar.gz
python3-pyaudio: Fix cross builds
Do not poison include paths with build system include and lib dirs these paths get appended to cflags/ldflags when building the c extention Fixes | /mnt/b/yoe/master/build/tmp/work/cortexa72-cortexa53-crypto-yoe-linux/python3-pyaudio/0.2.13-r0/recipe-sysroot/usr/include/python3.11/pyconfig.h:23:10: fatal error: 'python3.11/pyconfig-32.h' file not found | 23 | #include <python3.11/pyconfig-32.h> | | ^~~~~~~~~~~~~~~~~~~~~~~~~~ | 1 error generated. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Trevor Gamblin <tgamblin@baylibre.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch b/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch
new file mode 100644
index 0000000000..a71902a362
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch
@@ -0,0 +1,28 @@
1From d94518b558c1812aecb87d8ef19d75c2df1b98a5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 26 Jul 2023 19:54:19 -0700
4Subject: [PATCH] Remove absolute paths into build machine system dirs
5
6This ensures that it does not add /usr/include and /usr/local/include/
7into cflags
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 setup.py | 2 --
13 1 file changed, 2 deletions(-)
14
15--- a/setup.py
16+++ b/setup.py
17@@ -111,11 +111,6 @@ def setup_extension():
18 # the standard portaudio cmake settings. For details, see:
19 # https://devblogs.microsoft.com/cppblog/vcpkg-updates-static-linking-is-now-available/
20 extra_compile_args += ["/MT"]
21- else:
22- # GNU/Linux and other posix-like OSes will dynamically link to
23- # portaudio, installed by the package manager.
24- include_dirs += ['/usr/local/include', '/usr/include']
25- external_libraries_path += ['/usr/local/lib', '/usr/lib']
26
27 return Extension(
28 'pyaudio._portaudio',