summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-14 14:10:08 +0000
committerKhem Raj <raj.khem@gmail.com>2022-01-18 08:59:58 -0800
commit84769a963974cffc5d877e57a46a289a84bc293d (patch)
treed83cd83cd726a7d27cd8a8ce08e1b6bde4b0a59e /meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
parent214cfe90f7ce72736d9814624550bb6935b842e7 (diff)
downloadmeta-openembedded-84769a963974cffc5d877e57a46a289a84bc293d.tar.gz
python3-pycrypto: remove obsolete pycrypto module
pycrypto hasn't had a commit upstream since June 2014, which for a security-critical module is not a good sign. Everyone has migrated to the pycryptodome or cryptography modules, so remove pycrypto from meta-python. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
deleted file mode 100644
index 712f3e8dde..0000000000
--- a/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23