diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-07-31 16:22:20 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-03 17:42:47 -0700 |
commit | c3e5c9871025fcecf7398ef3996d0c2f93a0b7bb (patch) | |
tree | 03ec8e47c2107eda21b1d055e242c4f1139b0a1c /meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb | |
parent | 3fae19d9d4de5601aaec0e7ac40d57c6104e2848 (diff) | |
download | meta-openembedded-c3e5c9871025fcecf7398ef3996d0c2f93a0b7bb.tar.gz |
python3-pymongo: Upgrade 3.10.1 -> 3.11.0
Upgrade to release 3.11.0:
- Added support for MongoDB 4.4.
- Fixed a bug in change streams that could cause PyMongo to miss
some change documents when resuming a stream that was started
without a resume token and whose first batch did not contain any
change documents.
- Fixed an bug where using gevent.Timeout to timeout an operation
could lead to a deadlock.
For more details:
https://pymongo.readthedocs.io/en/3.11.0/changelog.html
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb new file mode 100644 index 0000000000..635de22d20 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" | ||
2 | DESCRIPTION = "\ | ||
3 | The PyMongo distribution contains tools for interacting with MongoDB \ | ||
4 | database from Python. The bson package is an implementation of the BSON \ | ||
5 | format for Python. The pymongo package is a native Python driver for \ | ||
6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." | ||
7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" | ||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | ||
10 | |||
11 | SRC_URI[md5sum] = "5d166c8f9500c83314deadebb95b6fd5" | ||
12 | SRC_URI[sha256sum] = "076a7f2f7c251635cf6116ac8e45eefac77758ee5a77ab7bd2f63999e957613b" | ||
13 | |||
14 | inherit pypi setuptools3 | ||
15 | |||
16 | PACKAGES =+ "${PYTHON_PN}-bson" | ||
17 | |||
18 | FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" | ||
19 | |||
20 | RDEPENDS_${PYTHON_PN}-bson += " \ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-json \ | ||
23 | ${PYTHON_PN}-netclient \ | ||
24 | ${PYTHON_PN}-numbers \ | ||
25 | ${PYTHON_PN}-threading \ | ||
26 | " | ||
27 | |||
28 | RDEPENDS_${PN} += " \ | ||
29 | ${PYTHON_PN}-bson \ | ||
30 | ${PYTHON_PN}-pprint \ | ||
31 | " | ||