summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-01-12 17:36:21 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-18 08:59:58 -0800
commitf1a500d166a51717e11f07219acf85f71e2ecdac (patch)
tree979cb85da513d36992dd4addd3280f7be4a2d571 /meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
parent9af9bb0819e94db8f71a5c9b38c52cdd8baace64 (diff)
downloadmeta-openembedded-f1a500d166a51717e11f07219acf85f71e2ecdac.tar.gz
python3-pymongo: upgrade 4.0 -> 4.0.1
changelog: =============================================================================== :meth:`pymongo.collection.Collection.update_one`, :meth:`pymongo.collection.Collection.update_many`, :meth:`pymongo.collection.Collection.delete_one`, :meth:`pymongo.collection.Collection.delete_many`, :meth:`pymongo.collection.Collection.aggregate`, :meth:`pymongo.collection.Collection.find_one_and_delete`, :meth:`pymongo.collection.Collection.find_one_and_replace`, :meth:`pymongo.collection.Collection.find_one_and_update`, and :meth:`pymongo.collection.Collection.find` all support a new keyword argument let which is a map of parameter names and values. Parameters can then be accessed as variables in an aggregate expression context. :meth:`~pymongo.collection.Collection.aggregate` now supports $merge and $out executing on secondaries on MongoDB >=5.0. aggregate() now always obeys the collection's :attr:`read_preference` on MongoDB >= 5.0. Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb b/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
new file mode 100644
index 0000000000..8eb0833fd0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI[sha256sum] = "13d0624c13a91da71fa0d960205d93b3d98344481be865ee7cc238c972d41d73"
12
13inherit pypi setuptools3
14
15PACKAGES =+ "${PYTHON_PN}-bson"
16
17FILES:${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
18
19RDEPENDS:${PYTHON_PN}-bson += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-bson \
29 ${PYTHON_PN}-pprint \
30"