summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-06-12 10:57:57 +0800
committerKhem Raj <raj.khem@gmail.com>2024-06-11 22:02:00 -0700
commit372f830c6860b0d279997e81b54fa50c1e63e9f8 (patch)
tree46a8bdafc57f40fb152b982aa0ac86692df8e5a6 /meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb
parent2a4dac7e4d1914cb7d2dc8d0f88c967758243ed5 (diff)
downloadmeta-openembedded-372f830c6860b0d279997e81b54fa50c1e63e9f8.tar.gz
python3-pymongo: upgrade 4.6.1 -> 4.7.2
Changelog: ============= Fixed a bug where PyMongo could not be used with the Nuitka compiler. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb b/meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb
new file mode 100644
index 0000000000..2951f8f85b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymongo_4.7.2.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI[sha256sum] = "9024e1661c6e40acf468177bf90ce924d1bc681d2b244adda3ed7b2f4c4d17d7"
12
13inherit pypi setuptools3
14
15PACKAGES =+ "python3-bson"
16
17FILES:python3-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
18
19RDEPENDS:python3-bson += " \
20 python3-datetime \
21 python3-json \
22 python3-netclient \
23 python3-numbers \
24 python3-threading \
25"
26
27RDEPENDS:${PN} += " \
28 python3-bson \
29 python3-pprint \
30"