summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-28 08:33:05 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-01 09:06:56 -0800
commit2dcff9296a35e0487e3c51836a5978820c9d95df (patch)
tree6f84c123426330116643cf6dafa530d64c08cad6 /meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch
parent42c0a75600aabb285024816a010d3c67218448ff (diff)
downloadmeta-openembedded-2dcff9296a35e0487e3c51836a5978820c9d95df.tar.gz
python3-pynetlinux: patch to use setuptools
setup.py bdist_wheel does not work with distutils (which is deprecated anyway). Add a patch to switch to setuptools to allow the wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch
new file mode 100644
index 0000000000..35bc4a6bd1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch
@@ -0,0 +1,32 @@
1From a36abadfb2d135260bef7703a1d0b56e6aa7eeff Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Mon, 28 Feb 2022 08:21:33 -0800
4Subject: [PATCH] setup.py: switch to setuptools
5
6In Python 3.10, 'distutils' has been deprecated and is slated for
7removal in Python 3.12.
8
9Switch from 'distutils.core' to 'setuptools'. This also allows for the
10'wheel' binary archive format to be built with 'setup.py bdist_wheel'.
11
12Upstream-Status: Submitted
13[https://github.com/rlisagor/pynetlinux/pull/12]
14
15Signed-off-by: Tim Orling <tim.orling@konsulko.com>
16---
17 setup.py | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/setup.py b/setup.py
21index 670e064..45f1053 100755
22--- a/setup.py
23+++ b/setup.py
24@@ -1,4 +1,4 @@
25-from distutils.core import setup
26+from setuptools import setup
27
28 setup(
29 name = "pynetlinux",
30--
312.30.2
32