diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-19 15:58:07 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-19 19:18:30 -0700 |
commit | 45e77092f5b27c7b1333d17146137f6735339754 (patch) | |
tree | 064cc72a85af31841c0dfa69a69d2588dcccbb3d /meta-python/recipes-devtools/python/python3-pyproj/rpath.patch | |
parent | 1f2f07c30f034f079ff3b7d16605ec2f0c2da0ee (diff) | |
download | meta-openembedded-45e77092f5b27c7b1333d17146137f6735339754.tar.gz |
python3-pyproj: Fix buildpaths QA Error
This error is due to absolute paths leaking into ELF files due to
-rpath option in compiler cmdline, therefore patch them out.
Apply patch [1] from Debian
[1] https://sources.debian.org/data/main/p/python-pyproj/3.6.1-4/debian/patches/rpath.patch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyproj/rpath.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyproj/rpath.patch | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch b/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch new file mode 100644 index 0000000000..347996a808 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Description: Don't set RPATH in libraries. | ||
2 | Author: Bas Couwenberg <sebastic@debian.org> | ||
3 | Forwarded: not-needed | ||
4 | |||
5 | Upstream-Status: Inappropriate [OE-Specific] | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- a/setup.py | ||
8 | +++ b/setup.py | ||
9 | @@ -194,9 +194,6 @@ def get_extension_modules(): | ||
10 | ext_options = { | ||
11 | "include_dirs": include_dirs, | ||
12 | "library_dirs": library_dirs, | ||
13 | - "runtime_library_dirs": ( | ||
14 | - library_dirs if os.name != "nt" and sys.platform != "cygwin" else None | ||
15 | - ), | ||
16 | "libraries": get_libraries(library_dirs), | ||
17 | } | ||
18 | # setup cythonized modules | ||