diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-07-07 11:13:44 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-07 08:59:27 -0700 |
commit | 693edd5dfb3fd0ceb29022a704e6fe27aeed86f4 (patch) | |
tree | 5c24c0330f35994809e2b0459cfd29b7cae76ac5 /meta-python/recipes-devtools/python/python3-redis_4.6.0.bb | |
parent | 547e701369b934eaff137358b2b71e687c1dbf12 (diff) | |
download | meta-openembedded-693edd5dfb3fd0ceb29022a704e6fe27aeed86f4.tar.gz |
python3-redis: upgrade 4.5.5 -> 4.6.0
Changelog:
==========
Experimental Features
-----------------------
Support JSON.MERGE command (#2761)
Support JSON.MSET command (#2766)
New Features
-------------
Extract abstract async connection class (#2734)
Add support for WAITAOF (#2760)
Introduce OutOfMemoryError exception for Redis write command rejections due to OOM errors (#2778)
Add WITHSCORE argument to ZRANK (#2758)
Add support for sharded pubsub in sync client (#2762)
Bug Fixes
-----------
Fix dead weakref in sentinel connection causing ReferenceError (#2767) (#2771)
Fix Key Error in parse_xinfo_stream (#2788)
Remove unnecessary __del__ handlers (#2755)
Added support for missing argument to SentinelManagedConnection.read_response() (#2756)
Fixed resp3 dict parse response (#2757)
Maintenance
-------------
Fix type hint for retry_on_error in async cluster (#2804)
Clean up documents and fix some redirects (#2801)
Add unit tests for the connect method of all Redis connection classes (#2631)
Docstring formatting fix (#2796)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-redis_4.6.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-redis_4.6.0.bb | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-redis_4.6.0.bb b/meta-python/recipes-devtools/python/python3-redis_4.6.0.bb new file mode 100644 index 0000000000..47eb7c2096 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-redis_4.6.0.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Python client for Redis key-value store" | ||
2 | DESCRIPTION = "The Python interface to the Redis key-value store." | ||
3 | HOMEPAGE = "http://github.com/andymccurdy/redis-py" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1db1f331d351900707368237cc4880cf" | ||
6 | |||
7 | SRC_URI[sha256sum] = "585dc516b9eb042a619ef0a39c3d7d55fe81bdb4df09a52c9cdde0d07bf1aa7d" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS:${PN} += " \ | ||
12 | python3-asyncio \ | ||
13 | python3-compression \ | ||
14 | python3-cryptography \ | ||
15 | python3-datetime \ | ||
16 | python3-json \ | ||
17 | python3-packaging \ | ||
18 | " | ||