summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2021-03-04 17:45:01 -0300
committerKhem Raj <raj.khem@gmail.com>2021-03-08 07:29:49 -0800
commit30335523547f262e550783ed699c273c916ec2d7 (patch)
treeaffad3504fa6bc9bf0a24de9ab594ea7f426a897 /meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
parent81136ec9bbd05b342cb9f53d547d77b35b716ad8 (diff)
downloadmeta-openembedded-30335523547f262e550783ed699c273c916ec2d7.tar.gz
python3-requests: Support idna version 3.1
Change idna required version to use python3-idna recipe that currently is on version 3.1. Without this change python-request doesn't work as the idna version doesn't match the required versions. When bump python-request recipe, verify if the upstream project bumped the idna version and drop this patch. As this recipe was tested with python3-idna_3.1 don't allow higher versions. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
new file mode 100644
index 0000000000..26332249da
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
@@ -0,0 +1,40 @@
1From fc45beed40a86c8fc38fc430765c1c5d2c9961c2 Mon Sep 17 00:00:00 2001
2From: Fabio Berton <fabio.berton@ossystems.com.br>
3Date: Thu, 4 Mar 2021 09:26:48 -0300
4Subject: [PATCH] setup.py: Support idna version 3.1
5Organization: O.S. Systems Software LTDA.
6
7Change idna required version to use python3-idna recipe that currently
8is on version 3.1.
9
10Without this change python-request doesn't work as the idna version
11doesn't match the required versions. When bump python-request recipe,
12verify if the upstream project bumped the idna version and drop this
13patch.
14
15As this recipe was tested with python3-idna_3.1 don't allow higher
16versions.
17
18Upstream-Status: Inappropriate [embedded specific]
19
20Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
21---
22 setup.py | 2 +-
23 1 file changed, 1 insertion(+), 1 deletion(-)
24
25diff --git a/setup.py b/setup.py
26index 7ba4b2a2..9d3b973e 100755
27--- a/setup.py
28+++ b/setup.py
29@@ -43,7 +43,7 @@ packages = ['requests']
30
31 requires = [
32 'chardet>=3.0.2,<5',
33- 'idna>=2.5,<3',
34+ 'idna>=2.5,<3.2',
35 'urllib3>=1.21.1,<1.27',
36 'certifi>=2017.4.17'
37
38--
392.30.1
40