diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-07-16 12:21:16 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-07-20 09:27:56 -0700 |
commit | bb00cfa7f7cdaffe397881f6c3f7e30d490a693d (patch) | |
tree | fe626aef9cde31c04014b73fbf0e7ace98240e89 /meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch | |
parent | 9a9a39b55987c75ed598694a79d13daf318ca20f (diff) | |
download | meta-openembedded-bb00cfa7f7cdaffe397881f6c3f7e30d490a693d.tar.gz |
python3-requests: Upgrade 2.25.1 -> 2.26.0
Upgrade to release 2.26.0:
- Requests now supports Brotli compression, if either the `brotli`
or `brotlicffi` package is installed
- `Session.send` now correctly resolves proxy configurations from
both the Session and Request. Behavior now matches
`Session.request`.
- Fixed a race condition in zip extraction when using Requests in
parallel from zip archive.
- Requests now supports `idna` 3.x on Python 3. `idna` 2.x will
continue to be used on Python 2 installations
Drop setup.py-Support-idna-version-3.1.patch because the issue
with idna version has been solved in the upstream for Python 3.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch | 40 |
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch deleted file mode 100644 index 26332249da..0000000000 --- a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From fc45beed40a86c8fc38fc430765c1c5d2c9961c2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Fabio Berton <fabio.berton@ossystems.com.br> | ||
3 | Date: Thu, 4 Mar 2021 09:26:48 -0300 | ||
4 | Subject: [PATCH] setup.py: Support idna version 3.1 | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Change idna required version to use python3-idna recipe that currently | ||
8 | is on version 3.1. | ||
9 | |||
10 | Without this change python-request doesn't work as the idna version | ||
11 | doesn't match the required versions. When bump python-request recipe, | ||
12 | verify if the upstream project bumped the idna version and drop this | ||
13 | patch. | ||
14 | |||
15 | As this recipe was tested with python3-idna_3.1 don't allow higher | ||
16 | versions. | ||
17 | |||
18 | Upstream-Status: Inappropriate [embedded specific] | ||
19 | |||
20 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
21 | --- | ||
22 | setup.py | 2 +- | ||
23 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/setup.py b/setup.py | ||
26 | index 7ba4b2a2..9d3b973e 100755 | ||
27 | --- a/setup.py | ||
28 | +++ b/setup.py | ||
29 | @@ -43,7 +43,7 @@ packages = ['requests'] | ||
30 | |||
31 | requires = [ | ||
32 | 'chardet>=3.0.2,<5', | ||
33 | - 'idna>=2.5,<3', | ||
34 | + 'idna>=2.5,<3.2', | ||
35 | 'urllib3>=1.21.1,<1.27', | ||
36 | 'certifi>=2017.4.17' | ||
37 | |||
38 | -- | ||
39 | 2.30.1 | ||
40 | |||