diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2023-12-18 19:09:01 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-18 22:17:25 -0800 |
commit | fb7023bd3c2038fc61f40d3ed95c96a74cef2368 (patch) | |
tree | dc7641eb7d5d536c087dc9b094bafcdfb5003d00 /meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch | |
parent | 1d887eede793e8e3da3a75f3ffead7ea1d867698 (diff) | |
download | meta-openembedded-fb7023bd3c2038fc61f40d3ed95c96a74cef2368.tar.gz |
python3-rlp: upgrade 3.0.0 -> 4.0.0
Upgrade to version 4.0.0:
- repr() now returns an evaluatable string, like
MyRLPObj(my_int_field=1, my_str_field="a_str")
- Convert .format strings to f-strings
- Add autoflake linting and move config to pyproject.toml
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch | 37 |
1 files changed, 0 insertions, 37 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch deleted file mode 100644 index 0ab012a982..0000000000 --- a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 5a2db801c6520be296cee9cba0e0e4ffac68430c Mon Sep 17 00:00:00 2001 | ||
2 | From: Bartosz Golaszewski <brgl@bgdev.pl> | ||
3 | Date: Wed, 11 May 2022 15:11:19 +0200 | ||
4 | Subject: [PATCH] setup: don't use setuptools-markdown | ||
5 | |||
6 | This project is deprecated and irrelevant for the functionality of | ||
7 | pyrlp. We don't support it in meta-python so just drop it from the | ||
8 | dependencies. | ||
9 | |||
10 | Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> | ||
11 | --- | ||
12 | Upstream-Status: Pending | ||
13 | |||
14 | setup.py | 2 -- | ||
15 | 1 file changed, 2 deletions(-) | ||
16 | |||
17 | diff --git a/setup.py b/setup.py | ||
18 | index 1055fb1..55fca24 100755 | ||
19 | --- a/setup.py | ||
20 | +++ b/setup.py | ||
21 | @@ -46,13 +46,11 @@ setup( | ||
22 | # *IMPORTANT*: Don't manually change the version here. See README for more. | ||
23 | version='3.0.0', | ||
24 | description="A package for Recursive Length Prefix encoding and decoding", | ||
25 | - long_description_markdown_filename='README.md', | ||
26 | author="jnnk", | ||
27 | author_email='jnnknnj@gmail.com', | ||
28 | url='https://github.com/ethereum/pyrlp', | ||
29 | packages=find_packages(exclude=["tests", "tests.*"]), | ||
30 | include_package_data=True, | ||
31 | - setup_requires=['setuptools-markdown'], | ||
32 | install_requires=[ | ||
33 | "eth-utils>=2.0.0,<3", | ||
34 | ], | ||
35 | -- | ||
36 | 2.34.1 | ||
37 | |||