diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2025-05-12 15:35:47 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-12 08:09:23 -0700 |
commit | 2efa96cecb50305aacd3b7df9c1aca036017dfeb (patch) | |
tree | 7eed6227da605162681954195da4a85cd77c658f /meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb | |
parent | 244997df0f2e8d0a3394ba665cee308216cf4003 (diff) | |
download | meta-openembedded-master.tar.gz |
python3-setproctitle: Upgrade 1.3.5 -> 1.3.6HEADmaster-nextmaster
Changelog:
- Add support for free-threading (issue #147)
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb b/meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb new file mode 100644 index 0000000000..e4a392726b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "A Python module to customize the process title" | ||
2 | DESCRIPTION = "The setproctitle module allows a process to change its \ | ||
3 | title (as displayed by system tools such as ps, top or MacOS Activity \ | ||
4 | Monitor)." | ||
5 | HOMEPAGE = "https://github.com/dvarrazzo/py-setproctitle" | ||
6 | BUGTRACKER = "https://github.com/dvarrazzo/py-setproctitle/issues" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=86d2d41b5f4f023f43466f8cb7adebaa" | ||
9 | |||
10 | inherit pypi setuptools3 ptest | ||
11 | |||
12 | SRC_URI[sha256sum] = "c9f32b96c700bb384f33f7cf07954bb609d35dd82752cef57fb2ee0968409169" | ||
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS:${PN}-ptest += "\ | ||
19 | libatomic-dev \ | ||
20 | packagegroup-core-buildessential \ | ||
21 | procps-ps \ | ||
22 | python3-dev \ | ||
23 | python3-multiprocessing \ | ||
24 | python3-pytest \ | ||
25 | python3-unittest-automake-output \ | ||
26 | " | ||
27 | |||
28 | do_install_ptest() { | ||
29 | install -d ${D}${PTEST_PATH}/tests | ||
30 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
31 | } | ||
32 | |||
33 | BBCLASSEXTEND = "native nativesdk" | ||
34 | |||
35 | INSANE_SKIP:${PN}-ptest = "dev-deps" | ||