diff options
author | Changqing Li <changqing.li@windriver.com> | 2020-03-09 14:04:28 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-03-09 11:26:36 -0700 |
commit | 41eb6e1a61ee416714149918489af975eba3dba6 (patch) | |
tree | 705b4e5617160cfd10a3602257b510754b77a462 /meta-python/recipes-devtools/python/python3-sqlparse | |
parent | 3173648279acb92d3e280c5148069ff7c7648e41 (diff) | |
download | meta-openembedded-41eb6e1a61ee416714149918489af975eba3dba6.tar.gz |
python3-sqlparse: change shebang to python3
we have offcially dropped python2, so it is possible
that our code run on python3 only host, so change
shebang to python3 to avoid error like:
python: command not found
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch b/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch new file mode 100644 index 0000000000..ad6c50ff77 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch | |||
@@ -0,0 +1,51 @@ | |||
1 | From 10c9d3341d64d697f678a64ae707f6bda21565bb Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Mon, 9 Mar 2020 13:10:37 +0800 | ||
4 | Subject: [PATCH] sqlparse: change shebang to python3 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Don't send upstream since upstream still support python2, | ||
9 | we can only make this change after python2 is offcially | ||
10 | dropped. | ||
11 | |||
12 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
13 | --- | ||
14 | setup.py | 2 +- | ||
15 | sqlparse/__main__.py | 2 +- | ||
16 | sqlparse/cli.py | 2 +- | ||
17 | 3 files changed, 3 insertions(+), 3 deletions(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index 345d0ce..ce3abc3 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -1,4 +1,4 @@ | ||
24 | -#!/usr/bin/env python | ||
25 | +#!/usr/bin/env python3 | ||
26 | # -*- coding: utf-8 -*- | ||
27 | # | ||
28 | # Copyright (C) 2009-2018 the sqlparse authors and contributors | ||
29 | diff --git a/sqlparse/__main__.py b/sqlparse/__main__.py | ||
30 | index 867d75d..dd0c074 100644 | ||
31 | --- a/sqlparse/__main__.py | ||
32 | +++ b/sqlparse/__main__.py | ||
33 | @@ -1,4 +1,4 @@ | ||
34 | -#!/usr/bin/env python | ||
35 | +#!/usr/bin/env python3 | ||
36 | # -*- coding: utf-8 -*- | ||
37 | # | ||
38 | # Copyright (C) 2009-2018 the sqlparse authors and contributors | ||
39 | diff --git a/sqlparse/cli.py b/sqlparse/cli.py | ||
40 | index 25555a5..8bf050a 100755 | ||
41 | --- a/sqlparse/cli.py | ||
42 | +++ b/sqlparse/cli.py | ||
43 | @@ -1,4 +1,4 @@ | ||
44 | -#!/usr/bin/env python | ||
45 | +#!/usr/bin/env python3 | ||
46 | # -*- coding: utf-8 -*- | ||
47 | # | ||
48 | # Copyright (C) 2009-2018 the sqlparse authors and contributors | ||
49 | -- | ||
50 | 2.7.4 | ||
51 | |||