summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-27 11:45:11 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-01 09:06:56 -0800
commit62a5f30896a3291d645785a2f658f62e336f91f7 (patch)
treee1184d66d6fa52d5b014273c48d8a3af607421db /meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
parent870a9bd263c51c47f718e2eb9b456a9d345c7330 (diff)
downloadmeta-openembedded-62a5f30896a3291d645785a2f658f62e336f91f7.tar.gz
python3-twofish: patch to use setuptools
setup.py bdist_wheel does not work with distutils (which is deprecated anyway). Add a patch to switch to setuptools to allow wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
new file mode 100644
index 0000000000..99e5c6c517
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
@@ -0,0 +1,26 @@
1From fe10781bd15ed7a5c384dbf121f78f129995aa8f Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Sun, 27 Feb 2022 11:02:36 -0800
4Subject: [PATCH] setup.py: switch to setuptools
5
6Upstream-Status: Submitted
7[https://github.com/keybase/python-twofish/pull/9]
8
9Signed-off-by: Tim Orling <tim.orling@konsulko.com>
10---
11 setup.py | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/setup.py b/setup.py
15index fcc9546..bfc3273 100644
16--- a/setup.py
17+++ b/setup.py
18@@ -8,7 +8,7 @@ Copyright (c) 2013 Keybase
19 setup.py - build and package info
20 """
21
22-from distutils.core import setup, Extension
23+from setuptools import setup, Extension
24
25 twofish_module = Extension('_twofish',
26 sources=['twofish-0.3/twofish.c', 'twofish.c'],