diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-09-15 12:09:15 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-15 16:02:34 -0700 |
commit | 58cbef934361fa841d2bc6b1b50238f0c4b8c744 (patch) | |
tree | 2816983cb2d1fd2374fceb07b1dcf77765992e67 /meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | |
parent | dde0d656e1dd2e25d733e18bcfcf50f90eaddae9 (diff) | |
download | meta-openembedded-58cbef934361fa841d2bc6b1b50238f0c4b8c744.tar.gz |
python-ujson: Use python_setuptools_build_meta
Drop the patch to disable strip instead set the env variable.
set UJSON_BUILD_NO_STRIP=1 and get rid of one pending patch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | 37 |
1 files changed, 0 insertions, 37 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch deleted file mode 100644 index 8ba8ada556..0000000000 --- a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From aec3b64b0aaea0178b44ea65a204d76696e6a45e Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 10 Jan 2022 14:04:28 +0200 | ||
4 | Subject: [PATCH] setup.py: Do not strip debugging symbols | ||
5 | |||
6 | Do not strip debugging symbols from Linux binaries to avoid | ||
7 | bitbake build errors related to already-stripped. | ||
8 | |||
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
10 | --- | ||
11 | Upstream-Status: Pending | ||
12 | |||
13 | setup.py | 8 +------- | ||
14 | 1 file changed, 1 insertion(+), 7 deletions(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index b98963b..d42f07a 100644 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -19,13 +19,7 @@ if not dconv_libs: | ||
21 | dconv_source_files.extend(glob("./deps/double-conversion/double-conversion/*.cc")) | ||
22 | dconv_source_files.append("./lib/dconv_wrapper.cc") | ||
23 | |||
24 | -if platform.system() == "Linux" and environ.get("UJSON_BUILD_NO_STRIP", "0") not in ( | ||
25 | - "1", | ||
26 | - "True", | ||
27 | -): | ||
28 | - strip_flags = ["-Wl,--strip-all"] | ||
29 | -else: | ||
30 | - strip_flags = [] | ||
31 | +strip_flags = [] | ||
32 | |||
33 | module1 = Extension( | ||
34 | "ujson", | ||
35 | -- | ||
36 | 2.25.1 | ||
37 | |||