diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2022-01-10 14:21:34 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-11 17:50:55 -0800 |
commit | 7e63b7a3ac1561aed824ebd299c24f51da39ff95 (patch) | |
tree | d582e4bf9c228ba007eeda4753681f295b9adc02 /meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | |
parent | 25b9efc9b098b2faf8572b69d035a914a961534d (diff) | |
download | meta-openembedded-7e63b7a3ac1561aed824ebd299c24f51da39ff95.tar.gz |
python3-ujson: Upgrade 5.0.0 -> 5.1.0
Upgrade to release 5.1.0:
- Strip debugging symbols from Linux binaries
Add a patch in setup.py to disable striping debugging symbols for
Linux to avoid already-stripped build errors.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch new file mode 100644 index 0000000000..47da2b8cfc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From aec3b64b0aaea0178b44ea65a204d76696e6a45e Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 10 Jan 2022 14:04:28 +0200 | ||
4 | Subject: [PATCH] setup.py: Do not strip debugging symbols | ||
5 | |||
6 | Do not strip debugging symbols from Linux binaries to avoid | ||
7 | bitbake build errors related to already-stripped. | ||
8 | |||
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
10 | --- | ||
11 | setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 453dc31..962c507 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -6,7 +6,7 @@ from setuptools import Extension, setup | ||
19 | dconv_source_files = glob("./deps/double-conversion/double-conversion/*.cc") | ||
20 | dconv_source_files.append("./lib/dconv_wrapper.cc") | ||
21 | |||
22 | -strip_flags = ["-Wl,--strip-all"] if platform.system() == "Linux" else [] | ||
23 | +strip_flags = [] | ||
24 | |||
25 | module1 = Extension( | ||
26 | "ujson", | ||
27 | -- | ||
28 | 2.30.2 | ||
29 | |||