summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 19:03:09 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 16:43:10 -0700
commita3b439c990b50bddcd3637a3ed4f41c557a9b7ea (patch)
tree2796d09cff74cc949a13a2a11195902e9ce65a09 /meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
parentb79c99dbd4962de60eff5d706a932515951e66eb (diff)
downloadmeta-openembedded-a3b439c990b50bddcd3637a3ed4f41c557a9b7ea.tar.gz
python-websocket-client: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
index 9b6696ead1..a3e1bcf393 100644
--- a/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
+++ b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
@@ -1,2 +1,18 @@
1inherit setuptools3 1SUMMARY = "websocket client for python"
2require python-websocket-client.inc 2DESCRIPTION = "\
3websocket-client module is WebSocket client for python. \
4This provide the low level APIs for WebSocket. All APIs \
5are the synchronous functions."
6HOMEPAGE = "https://github.com/websocket-client/websocket-client"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c4c4a98fbc4836b81c8c64d6ecb01fc1"
9
10SRC_URI[md5sum] = "89484bd5dac71123ae6a09b2f90fe62c"
11SRC_URI[sha256sum] = "1fd5520878b68b84b5748bb30e592b10d0a91529d5383f74f4964e72b297fd3a"
12
13PYPI_PACKAGE = "websocket_client"
14inherit pypi setuptools3
15
16RDEPENDS_${PN} = "\
17 ${PYTHON_PN}-six \
18"