diff options
author | Tim Orling <ticotimo@gmail.com> | 2023-12-24 09:05:56 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-29 09:04:23 -0800 |
commit | f8d66f3174b0453d9235b7f11bbe578a31f96f37 (patch) | |
tree | ef25151fbd1dfd6fcba938217bd64f5a9a0a69b8 /meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch | |
parent | 813fb0def8a8bca81706496dd6f106692616a11f (diff) | |
download | meta-openembedded-f8d66f3174b0453d9235b7f11bbe578a31f96f37.tar.gz |
python3-yappi: upgrade 1.4.0 -> 1.6.0; fix ptests
* Switch to the python_setuptools_build_meta PEP-517 backend
* Refactor and submit 0001-Fix-imports-for-ptests.patch
- split out the Windows -> Unix line endings conversion
- https://github.com/sumerc/yappi/pull/164
* Drop 0002-add-3.11-to-the-setup.patch; upstream added 3.11 and 3.12
* Drop install of yappi.py in ptest; use site-packages as intended
* Drop complex run-ptest and simply run 'pytest --automake'
* Move out of "problems" group to "slow" group in ptest-packageslists-meta-python.inc
- can now build meta-python-image-ptest-python3-yappi
- tests take about 45 seconds
https://github.com/sumerc/yappi/blob/1.6.0/CHANGELOG
1.6.0 (2023-12-07)
- Drop support 2.7-3.5 and clean backward compatible code (pull/152)
- Add Python 3.12 wheels
1.5.1 (2023-12-06)
- Add support for Python 3.12
- Fix child callgrind functions disappear
Signed-off-by: Tim Orling <ticotimo@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch | 26 |
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch b/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch deleted file mode 100644 index d40bd2b7cc..0000000000 --- a/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 38afdacf526410f970afc58e147c7377c6c7112c Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?S=C3=BCmer=20Cip?= <sumer.cip@platform.sh> | ||
3 | Date: Fri, 25 Nov 2022 15:58:03 +0300 | ||
4 | Subject: [PATCH 2/2] add 3.11 to the setup | ||
5 | |||
6 | --- | ||
7 | Upstream-Status: Pending | ||
8 | |||
9 | setup.py | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/setup.py b/setup.py | ||
13 | index d006787..96e2a66 100644 | ||
14 | --- a/setup.py | ||
15 | +++ b/setup.py | ||
16 | @@ -56,6 +56,7 @@ CLASSIFIERS = [ | ||
17 | 'Programming Language :: Python :: 3.8', | ||
18 | 'Programming Language :: Python :: 3.9', | ||
19 | 'Programming Language :: Python :: 3.10', | ||
20 | + 'Programming Language :: Python :: 3.11', | ||
21 | 'Programming Language :: Python :: Implementation :: CPython', | ||
22 | 'Operating System :: OS Independent', | ||
23 | 'Topic :: Software Development :: Libraries', | ||
24 | -- | ||
25 | 2.30.2 | ||
26 | |||