diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-08-27 17:54:59 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-31 08:27:09 -0700 |
commit | 0507ca296bfa6ea6a88c164b1344f592361486df (patch) | |
tree | 5169dbe44499d5a587a4952ef83b9533e8c1d8f5 /meta-python/recipes-devtools/python | |
parent | ec486ac8437dd8c68bc0aaa9c76c270a3d9cd0fd (diff) | |
download | meta-openembedded-0507ca296bfa6ea6a88c164b1344f592361486df.tar.gz |
python3-flask-migrate: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-migrate.inc | 14 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb | 16 |
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-migrate.inc b/meta-python/recipes-devtools/python/python-flask-migrate.inc deleted file mode 100644 index 5202f8be08..0000000000 --- a/meta-python/recipes-devtools/python/python-flask-migrate.inc +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "SQLAlchemy database migrations for Flask applications using Alembic" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b69377f79f3f48c661701236d5a6a85" | ||
4 | |||
5 | SRC_URI[md5sum] = "bedeb0366740fda6912fea683be11968" | ||
6 | SRC_URI[sha256sum] = "a96ff1875a49a40bd3e8ac04fce73fdb0870b9211e6168608cbafa4eb839d502" | ||
7 | |||
8 | PYPI_PACKAGE = "Flask-Migrate" | ||
9 | |||
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-flask-sqlalchemy \ | ||
12 | ${PYTHON_PN}-alembic \ | ||
13 | ${PYTHON_PN}-flask \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb b/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb index c98cbfddb0..78ec665ef7 100644 --- a/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb +++ b/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb | |||
@@ -1,2 +1,16 @@ | |||
1 | DESCRIPTION = "SQLAlchemy database migrations for Flask applications using Alembic" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b69377f79f3f48c661701236d5a6a85" | ||
4 | |||
5 | SRC_URI[md5sum] = "bedeb0366740fda6912fea683be11968" | ||
6 | SRC_URI[sha256sum] = "a96ff1875a49a40bd3e8ac04fce73fdb0870b9211e6168608cbafa4eb839d502" | ||
7 | |||
8 | PYPI_PACKAGE = "Flask-Migrate" | ||
9 | |||
1 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |
2 | require python-flask-migrate.inc | 11 | |
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-flask-sqlalchemy \ | ||
14 | ${PYTHON_PN}-alembic \ | ||
15 | ${PYTHON_PN}-flask \ | ||
16 | " | ||