diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-02-12 17:07:17 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-12 08:56:16 -0800 |
commit | 09e784889f17d46a0b5dca59855bb75ffe449eae (patch) | |
tree | 6cb984aec4130d194163781c23103d52f216d48d /meta-python/recipes-devtools/python | |
parent | ab943a9811a11a82e2dcd137bd4a0117fe39895f (diff) | |
download | meta-openembedded-09e784889f17d46a0b5dca59855bb75ffe449eae.tar.gz |
python3-sentry-sdk: upgrade 1.13.0 -> 1.15.0
Various fixes & improvements
=============================
New: Add Huey Integration
Profiling: Do not send single sample profiles (#1879)
Profiling: Add additional test coverage for profiler (#1877)
Profiling: Always use builtin time.sleep (#1869)
Profiling: Defaul in_app decision to None (#1855)
Profiling: Remove use of threading.Event (#1864)
Profiling: Enable profiling on all transactions (#1797)
FastAPI: Fix check for Starlette in FastAPI integration (#1868)
Flask: Do not overwrite default for username with email address in FlaskIntegration (#1873)
Tests: Add py3.11 to test-common (#1871)
Fix: Don't log whole event in before_send / event_processor drops (#1863)
Add before_send_transaction (#1840)
Django: Always remove values of Django session related cookies. (#1842)
Profiling: Enable profiling for ASGI frameworks (#1824)
Profiling: Better gevent support (#1822)
Profiling: Use co_qualname in python 3.11 (#1831)
OpenTelemetry: fix Use dict for sentry-trace context instead of tuple (#1847)
OpenTelemetry: fix extra dependency (#1825)
OpenTelemetry: fix NoOpSpan updates scope (#1834)
OpenTelemetry: Make sure to noop when there is no DSN (#1852)
FastAPI: Fix middleware being patched multiple times (#1841)
Starlette: Avoid import of pkg_resource with Starlette integration (#1836)
Removed code coverage target (#1862)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sentry-sdk_1.15.0.bb (renamed from meta-python/recipes-devtools/python/python3-sentry-sdk_1.13.0.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.13.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.15.0.bb index 001ff6082c..b3ce17451c 100644 --- a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.13.0.bb +++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.15.0.bb | |||
@@ -15,7 +15,7 @@ RDEPENDS:${PN} += "\ | |||
15 | ${PYTHON_PN}-datetime \ | 15 | ${PYTHON_PN}-datetime \ |
16 | " | 16 | " |
17 | 17 | ||
18 | SRC_URI[sha256sum] = "72da0766c3069a3941eadbdfa0996f83f5a33e55902a19ba399557cfee1dddcc" | 18 | SRC_URI[sha256sum] = "69ecbb2e1ff4db02a06c4f20f6f69cb5dfe3ebfbc06d023e40d77cf78e9c37e7" |
19 | 19 | ||
20 | PYPI_PACKAGE = "sentry-sdk" | 20 | PYPI_PACKAGE = "sentry-sdk" |
21 | 21 | ||