summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-02 10:57:10 -0700
committerKhem Raj <raj.khem@gmail.com>2019-11-02 11:07:22 -0700
commit15d60dd3d0d0e901d11dab4be0f88235ae00cfa5 (patch)
treed002e34780da11837705086d439f3ee458d9691a /meta-python/recipes-devtools/python
parent31693faa26c9b4d3e49532cd772471b26c8c996a (diff)
downloadmeta-openembedded-15d60dd3d0d0e901d11dab4be0f88235ae00cfa5.tar.gz
python-docutils: Upgrade to 0.15.2
- License-Update: Formatting changes due to change in SRC_URI - This is reflected as latest release on PyPI - Add python3 variant - Add python3 variant to meta-python packagegroup Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb18
-rw-r--r--meta-python/recipes-devtools/python/python-docutils_0.15.2.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb15
3 files changed, 30 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb b/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
deleted file mode 100644
index 68436a1a54..0000000000
--- a/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=35a23d42b615470583563132872c97d6"
6
7DEPENDS = "python"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/docutils/docutils-${PV}.tar.gz"
10SRC_URI[md5sum] = "2f4bee6451958252f7bec71f18b05be3"
11SRC_URI[sha256sum] = "3caee0bcb2a49fdf24fcfa70849a60abb7a181aa68b030f7cb7494096181830c"
12
13S = "${WORKDIR}/docutils-${PV}"
14
15inherit distutils
16
17BBCLASSEXTEND = "native"
18
diff --git a/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb b/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb
new file mode 100644
index 0000000000..d26e81908b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7a4646907ab9083c826280b19e103106"
6
7inherit pypi setuptools
8
9PYPI_PACKAGE = "docutils"
10
11SRC_URI[md5sum] = "e26a308d8000b0bed7416a633217c676"
12SRC_URI[sha256sum] = "a2aeea129088da402665e92e0b25b04b073c04b2dce4ab65caaa38b7ce2e1a99"
13
14BBCLASSEXTEND = "native"
15
diff --git a/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb b/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb
new file mode 100644
index 0000000000..321f55572f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7a4646907ab9083c826280b19e103106"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "docutils"
10
11SRC_URI[md5sum] = "e26a308d8000b0bed7416a633217c676"
12SRC_URI[sha256sum] = "a2aeea129088da402665e92e0b25b04b073c04b2dce4ab65caaa38b7ce2e1a99"
13
14BBCLASSEXTEND = "native"
15