diff options
author | Adrian Bunk <bunk@stusta.de> | 2019-08-30 18:50:59 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-30 09:27:57 -0700 |
commit | 31a55b947d077c9ad9b61f30bf616ca32c425192 (patch) | |
tree | c215892c0431cd0fbe6965ac4c6e6f0d130ffe34 /meta-python/recipes-devtools/python | |
parent | 9d559933d7243969777625c7a66511fc43f1f2a0 (diff) | |
download | meta-openembedded-31a55b947d077c9ad9b61f30bf616ca32c425192.tar.gz |
Remove bogus COMMON_LICENSE_DIR usage in LIC_FILES_CHKSUM
Using COMMON_LICENSE_DIR in LIC_FILES_CHKSUM of downloaded
code is never the right thing to do, there must be some
license information and that has to be checked instead.
In several cases the claimed LICENSE was also incorrect.
Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
9 files changed, 13 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb index ffb5beb570..002da046c4 100644 --- a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb +++ b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb | |||
@@ -8,8 +8,8 @@ RDEPENDS_${PN} = "python-docutils \ | |||
8 | python-resource \ | 8 | python-resource \ |
9 | " | 9 | " |
10 | 10 | ||
11 | LICENSE = "Apache-2.0" | 11 | LICENSE = "Apache-2.0 & GPLv3" |
12 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" | 12 | LIC_FILES_CHKSUM = "file://README;md5=2695c853a2cafc33e68a1d972889ebd2" |
13 | 13 | ||
14 | inherit pypi setuptools | 14 | inherit pypi setuptools |
15 | 15 | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio-tools.inc b/meta-python/recipes-devtools/python/python-grpcio-tools.inc index 91cc62f40f..1a15c48de0 100644 --- a/meta-python/recipes-devtools/python/python-grpcio-tools.inc +++ b/meta-python/recipes-devtools/python/python-grpcio-tools.inc | |||
@@ -5,8 +5,8 @@ SECTION = "devel/python" | |||
5 | DEPENDS_append = "${PYTHON_PN}-grpcio" | 5 | DEPENDS_append = "${PYTHON_PN}-grpcio" |
6 | RDEPENDS_${PN} = "${PYTHON_PN}-grpcio" | 6 | RDEPENDS_${PN} = "${PYTHON_PN}-grpcio" |
7 | 7 | ||
8 | LICENSE = "BSD-3-Clause" | 8 | LICENSE = "Apache-2.0" |
9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | 9 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
10 | 10 | ||
11 | inherit pypi | 11 | inherit pypi |
12 | 12 | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio.inc b/meta-python/recipes-devtools/python/python-grpcio.inc index 7d3675c455..c5762b26b2 100644 --- a/meta-python/recipes-devtools/python/python-grpcio.inc +++ b/meta-python/recipes-devtools/python/python-grpcio.inc | |||
@@ -17,8 +17,8 @@ RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ | |||
17 | ${PYTHON_PN}-six \ | 17 | ${PYTHON_PN}-six \ |
18 | " | 18 | " |
19 | 19 | ||
20 | LICENSE = "BSD-3-Clause" | 20 | LICENSE = "Apache-2.0" |
21 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
22 | 22 | ||
23 | inherit pypi | 23 | inherit pypi |
24 | 24 | ||
diff --git a/meta-python/recipes-devtools/python/python-intervals.inc b/meta-python/recipes-devtools/python/python-intervals.inc index 1ecca3524b..a915e09f90 100644 --- a/meta-python/recipes-devtools/python/python-intervals.inc +++ b/meta-python/recipes-devtools/python/python-intervals.inc | |||
@@ -2,8 +2,8 @@ DESCRIPTION = "Interval arithmetic for Python" | |||
2 | HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals" | 2 | HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals" |
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | 4 | ||
5 | LICENSE = "BSD-3-Clause" | 5 | LICENSE = "LGPLv3" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab" |
7 | 7 | ||
8 | PYPI_PACKAGE := "python-intervals" | 8 | PYPI_PACKAGE := "python-intervals" |
9 | 9 | ||
diff --git a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb index 9ad865d406..20ea018045 100644 --- a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb +++ b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb | |||
@@ -5,7 +5,7 @@ SECTION = "devel/python" | |||
5 | RDEPENDS_${PN} = "python-threading" | 5 | RDEPENDS_${PN} = "python-threading" |
6 | 6 | ||
7 | LICENSE = "MIT" | 7 | LICENSE = "MIT" |
8 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72" |
9 | 9 | ||
10 | inherit pypi setuptools | 10 | inherit pypi setuptools |
11 | 11 | ||
diff --git a/meta-python/recipes-devtools/python/python-pint.inc b/meta-python/recipes-devtools/python/python-pint.inc index 53f7783934..2bc8e4ab63 100644 --- a/meta-python/recipes-devtools/python/python-pint.inc +++ b/meta-python/recipes-devtools/python/python-pint.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals" | |||
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | 4 | ||
5 | LICENSE = "BSD-3-Clause" | 5 | LICENSE = "BSD-3-Clause" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
7 | 7 | ||
8 | PYPI_PACKAGE := "Pint" | 8 | PYPI_PACKAGE := "Pint" |
9 | 9 | ||
diff --git a/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-python/recipes-devtools/python/python-protobuf.inc index ce95e66c98..5058d4bd31 100644 --- a/meta-python/recipes-devtools/python/python-protobuf.inc +++ b/meta-python/recipes-devtools/python/python-protobuf.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://developers.google.com/protocol-buffers/" | |||
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | 4 | ||
5 | LICENSE = "BSD-3-Clause" | 5 | LICENSE = "BSD-3-Clause" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e" |
7 | 7 | ||
8 | inherit pypi | 8 | inherit pypi |
9 | 9 | ||
diff --git a/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc b/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc index 9f07b6577a..bfcb023a2f 100644 --- a/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc +++ b/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "Robot Framework test library for serial connection" | 1 | SUMMARY = "Robot Framework test library for serial connection" |
2 | HOMEPAGE = "https://github.com/whosaysni/robotframework-seriallibrary" | 2 | HOMEPAGE = "https://github.com/whosaysni/robotframework-seriallibrary" |
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" | 4 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "b7c9565d54c30df7cd3f3c0e29adffa3" | 6 | SRC_URI[md5sum] = "b7c9565d54c30df7cd3f3c0e29adffa3" |
7 | SRC_URI[sha256sum] = "256ad60fc0b7df4be44d82c302f5ed8fad4935cda99e4b45942e3c88179d1e19" | 7 | SRC_URI[sha256sum] = "256ad60fc0b7df4be44d82c302f5ed8fad4935cda99e4b45942e3c88179d1e19" |
diff --git a/meta-python/recipes-devtools/python/python-scrypt.inc b/meta-python/recipes-devtools/python/python-scrypt.inc index fef6ec976c..aff86a594f 100644 --- a/meta-python/recipes-devtools/python/python-scrypt.inc +++ b/meta-python/recipes-devtools/python/python-scrypt.inc | |||
@@ -1,6 +1,6 @@ | |||
1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" | 1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" |
2 | LICENSE = "BSD-2-Clause" | 2 | LICENSE = "BSD-2-Clause" |
3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=cb641bc04cda31daea161b1bc15da69f" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc" |
4 | HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview" | 4 | HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview" |
5 | 5 | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-scrypt:" | 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-scrypt:" |