diff options
author | Randy MacLeod <Randy.MacLeod@windriver.com> | 2023-01-31 12:28:27 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-01 09:11:49 -0800 |
commit | 7b0e71e00ce1b003c96ef38ead72a9e02555afbe (patch) | |
tree | a39dc6cccdd249ef68a628d574b5e3a8d7042122 /meta-python/recipes-devtools/python | |
parent | 65ac92781f0f47013caba34aa1461b9a6ee7abe1 (diff) | |
download | meta-openembedded-7b0e71e00ce1b003c96ef38ead72a9e02555afbe.tar.gz |
python3-pillow: add ptest support
Add initial pillow ptest support.
The ptest result is:
====== 3600 passed 324 skipped, 2 xfailed, 1 xpassed in 62.41s (0:01:02) ======
for qemux86-64 with 2 GB RAM.
The skipped tests as summarized with:
# ptest-runner python3-pillow | tee log
# grep SKIPP log | cut -d"(" -f2- | cut -d")" -f1 | cut -d" " -f1 | sort | uniq -c| sort -n | tail -4
12 webp
13 Tk
14 Qt
84 raqm
Webp was explicityly disabled in 2018 in:
6cb4e90fc python3-pillow: add 5.4.1
I didn't test Tk or Qt and there isn't yet a recipe for libraqm:
https://github.com/HOST-Oman/libraqm
a library that encapsulates the logic for complex text layout.
Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pillow/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb | 22 |
2 files changed, 24 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow/run-ptest b/meta-python/recipes-devtools/python/python3-pillow/run-ptest new file mode 100644 index 0000000000..3385d68939 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pillow/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb index 403a987d1e..68c81029c0 100644 --- a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb +++ b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb | |||
@@ -8,10 +8,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1" | |||
8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ |
9 | file://0001-support-cross-compiling.patch \ | 9 | file://0001-support-cross-compiling.patch \ |
10 | file://0001-explicitly-set-compile-options.patch \ | 10 | file://0001-explicitly-set-compile-options.patch \ |
11 | file://run-ptest \ | ||
11 | " | 12 | " |
12 | SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8" | 13 | SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8" |
13 | 14 | ||
14 | inherit setuptools3 | 15 | inherit setuptools3 ptest |
15 | 16 | ||
16 | PIP_INSTALL_PACKAGE = "Pillow" | 17 | PIP_INSTALL_PACKAGE = "Pillow" |
17 | PIP_INSTALL_DIST_PATH = "${S}/dist" | 18 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
@@ -31,12 +32,31 @@ RDEPENDS:${PN} += " \ | |||
31 | ${PYTHON_PN}-numbers \ | 32 | ${PYTHON_PN}-numbers \ |
32 | " | 33 | " |
33 | 34 | ||
35 | RDEPENDS:${PN}-ptest += " \ | ||
36 | bash \ | ||
37 | ghostscript \ | ||
38 | jpeg-tools \ | ||
39 | libwebp \ | ||
40 | ${PYTHON_PN}-core \ | ||
41 | ${PYTHON_PN}-image \ | ||
42 | ${PYTHON_PN}-mmap \ | ||
43 | ${PYTHON_PN}-pytest \ | ||
44 | ${PYTHON_PN}-pytest-timeout \ | ||
45 | ${PYTHON_PN}-resource \ | ||
46 | tk \ | ||
47 | " | ||
48 | |||
34 | CVE_PRODUCT = "pillow" | 49 | CVE_PRODUCT = "pillow" |
35 | 50 | ||
36 | S = "${WORKDIR}/git" | 51 | S = "${WORKDIR}/git" |
37 | 52 | ||
38 | RPROVIDES:${PN} += "python3-imaging" | 53 | RPROVIDES:${PN} += "python3-imaging" |
39 | 54 | ||
55 | do_install_ptest() { | ||
56 | install -d ${D}${PTEST_PATH}/Tests | ||
57 | cp -rf ${S}/Tests ${D}${PTEST_PATH}/ | ||
58 | } | ||
59 | |||
40 | BBCLASSEXTEND = "native" | 60 | BBCLASSEXTEND = "native" |
41 | 61 | ||
42 | SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da" | 62 | SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da" |