summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-02-27 16:12:02 +0800
committerKhem Raj <raj.khem@gmail.com>2023-02-27 09:43:09 -0800
commite8a22081a27b2f81e68369f79dcdbe423134993c (patch)
tree0aa5440c3d8dbaab7f9be9fecc7b4bba10a62a4e /meta-python/recipes-devtools/python
parent549919352ccedee378fb4c2c3c3e39a6c9ee8fd7 (diff)
downloadmeta-openembedded-e8a22081a27b2f81e68369f79dcdbe423134993c.tar.gz
python3-simpleeval: upgrade 0.9.12 -> 0.9.13
Changelog: =========== Better handling of empty strings passed as input. Fix the shift safe number issue from 0.9.12 More minor pylint / etc fixes / cleanups (general code quality) separate .parse from #115 Allow setting up completely empty {} operators / functions ( #75 via #123 ) Add extra bit-ops from #87 Add @daxamin to contributors ? Version bump stuff. other readme tweaks star expressions, eg x = {"a": 1, "b": 2, **c} no-build.patch removed since it's included in 0.9.13 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch24
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb (renamed from meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb)7
2 files changed, 2 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
deleted file mode 100644
index 8302c3b298..0000000000
--- a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1Upstream-Status: Backport [https://github.com/danthedeckie/simpleeval/pull/119]
2Signed-off-by: Ross Burton <ross.burton@arm.com>
3
4From 08bc99211aec32882d5f1c83896eb5d72b9fb125 Mon Sep 17 00:00:00 2001
5From: Ross Burton <ross.burton@arm.com>
6Date: Mon, 23 May 2022 11:35:00 +0100
7Subject: [PATCH] pyproject.toml: remove build as a build-dependency
8
9pypa/build is one possible build tool, but not the only build tool. Forcing build to be present as a build dependency is meaningless: either the user is using build so obviously have build, or are using something else so having build is irrelevant.
10---
11 pyproject.toml | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/pyproject.toml b/pyproject.toml
15index 052a55a..416482b 100644
16--- a/pyproject.toml
17+++ b/pyproject.toml
18@@ -1,5 +1,5 @@
19 [build-system]
20-requires = ["setuptools>=30.3.0", "wheel", "build"]
21+requires = ["setuptools>=30.3.0", "wheel"]
22 build-backend = "setuptools.build_meta"
23
24 [tool.black]
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb
index c9cf33d023..35cd19ffef 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb
@@ -3,16 +3,13 @@ HOMEPAGE = "https://pypi.org/project/simpleeval/"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7" 4LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
5 5
6SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36" 6SRC_URI[sha256sum] = "4a30f9cc01825fe4c719c785e3762623e350c4840d5e6855c2a8496baaa65fac"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest
9 9
10BBCLASSEXTEND = "native nativesdk" 10BBCLASSEXTEND = "native nativesdk"
11 11
12SRC_URI += " \ 12SRC_URI += "file://run-ptest"
13 file://no-build.patch \
14 file://run-ptest \
15"
16 13
17RDEPENDS:${PN} += " \ 14RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-math \ 15 ${PYTHON_PN}-math \