diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2025-02-13 11:04:29 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-02-13 07:44:15 -0800 |
commit | fdd2b52d45310cf80f9738305854e45c1d8b5cfe (patch) | |
tree | 201a2d7ce68eb0eae5ae19146596891c2aa086f6 /meta-python/recipes-devtools/python | |
parent | dd96370cfca30fd69342ba71dc5094426d188d1b (diff) | |
download | meta-openembedded-fdd2b52d45310cf80f9738305854e45c1d8b5cfe.tar.gz |
python3-daemon: Upgrade 3.0.1 -> 3.1.2
Upgrade to release 3.1.2:
- In wheel, distribute only the Python packages that should be
installed.
- Migrate project code base from "flat layout" to "src layout"
License-Update: Use COPYING file
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-daemon/0001-Use-version-from-packaging-module-instead-of-setupto.patch | 44 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-daemon_3.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb) | 9 |
2 files changed, 4 insertions, 49 deletions
diff --git a/meta-python/recipes-devtools/python/python3-daemon/0001-Use-version-from-packaging-module-instead-of-setupto.patch b/meta-python/recipes-devtools/python/python3-daemon/0001-Use-version-from-packaging-module-instead-of-setupto.patch deleted file mode 100644 index 316f7d9618..0000000000 --- a/meta-python/recipes-devtools/python/python3-daemon/0001-Use-version-from-packaging-module-instead-of-setupto.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From b7418ab4a3232431373bf0680c6b74fef06910de Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 10 Aug 2024 22:44:08 -0700 | ||
4 | Subject: [PATCH] Use version from packaging module instead of setuptools extern | ||
5 | |||
6 | Fixes build problems when using PEP-575 build backend | ||
7 | |||
8 | |||
9 | Drop the patch on upgrading to >= 3.0.2 | ||
10 | |||
11 | Upstream-Status: Backport [https://pagure.io/fork/khemraj/python-daemon/c/3bbc46967d35cd7e05677018bdc9d552efaeea3e?branch=main] | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | test_version.py | 2 +- | ||
16 | version.py | 2 +- | ||
17 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/test_version.py b/test_version.py | ||
20 | index c43cd36..d0a124d 100644 | ||
21 | --- a/test_version.py | ||
22 | +++ b/test_version.py | ||
23 | @@ -23,7 +23,7 @@ import docutils.writers | ||
24 | import setuptools | ||
25 | import setuptools.command | ||
26 | import setuptools.dist | ||
27 | -from setuptools.extern.packaging.version import InvalidVersion | ||
28 | +from packaging.version import InvalidVersion | ||
29 | import testscenarios | ||
30 | import testtools | ||
31 | |||
32 | diff --git a/version.py b/version.py | ||
33 | index 20d3ef3..fbdc462 100644 | ||
34 | --- a/version.py | ||
35 | +++ b/version.py | ||
36 | @@ -36,7 +36,7 @@ import setuptools.command.build | ||
37 | import setuptools.command.build_py | ||
38 | import setuptools.command.egg_info | ||
39 | import setuptools.dist | ||
40 | -import setuptools.extern.packaging.version | ||
41 | +import packaging.version | ||
42 | |||
43 | |||
44 | def ensure_class_bases_begin_with(namespace, class_name, base_class): | ||
diff --git a/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb b/meta-python/recipes-devtools/python/python3-daemon_3.1.2.bb index cb85262b41..8cf5697d10 100644 --- a/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb +++ b/meta-python/recipes-devtools/python/python3-daemon_3.1.2.bb | |||
@@ -2,18 +2,17 @@ DESCRIPTION = "Library to implement a well-behaved Unix daemon process" | |||
2 | HOMEPAGE = "https://pagure.io/python-daemon/" | 2 | HOMEPAGE = "https://pagure.io/python-daemon/" |
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | 4 | ||
5 | DEPENDS += "python3-docutils-native" | 5 | DEPENDS += "python3-docutils-native python3-changelog-chug-native" |
6 | RDEPENDS:${PN} = "python3-docutils \ | 6 | RDEPENDS:${PN} = "python3-docutils \ |
7 | python3-lockfile (>= 0.10) \ | 7 | python3-lockfile (>= 0.10) \ |
8 | python3-resource \ | 8 | python3-resource \ |
9 | " | 9 | " |
10 | 10 | ||
11 | LICENSE = "Apache-2.0 & GPL-3.0-only" | 11 | LICENSE = "Apache-2.0 & GPL-3.0-only" |
12 | LIC_FILES_CHKSUM = "file://README;md5=a3a94c615dc969a70525f1eebbacf235" | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=55f76b1b31719284caf4bc3ecbb70d6f" |
13 | 13 | ||
14 | inherit pypi python_setuptools_build_meta | 14 | inherit pypi python_setuptools_build_meta |
15 | 15 | ||
16 | SRC_URI += "file://0001-Use-version-from-packaging-module-instead-of-setupto.patch" | 16 | SRC_URI[sha256sum] = "f7b04335adc473de877f5117e26d5f1142f4c9f7cd765408f0877757be5afbf4" |
17 | SRC_URI[sha256sum] = "6c57452372f7eaff40934a1c03ad1826bf5e793558e87fef49131e6464b4dae5" | ||
18 | 17 | ||
19 | PYPI_PACKAGE = "python-daemon" | 18 | PYPI_PACKAGE = "python_daemon" |