diff options
author | Tim Orling <ticotimo@gmail.com> | 2022-02-28 10:03:39 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-01 09:06:56 -0800 |
commit | 4c1065c55c680d74193efcbc525b5e3b88519644 (patch) | |
tree | e4e9c3a776115cc97b590157fe67c27edb80ebf7 /meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch | |
parent | fbb90ed4eeaf8065a8ccc9ab13dca14cc550a5b8 (diff) | |
download | meta-openembedded-4c1065c55c680d74193efcbc525b5e3b88519644.tar.gz |
python3-meh: patch to use setuptools
* Add patch to switch from 'distutils' to 'setuptools'
* Set PIP_INSTALL_PACKAGE = "python_meh"
* Install files to ${datadir} as intended
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch')
-rw-r--r-- | meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch new file mode 100644 index 0000000000..b616b3fad3 --- /dev/null +++ b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 034ac41561409ffc7836683331b6b94a641436e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Mon, 28 Feb 2022 09:41:02 -0800 | ||
4 | Subject: [PATCH] setup.py: switch from distutils to setuptools | ||
5 | |||
6 | In Python 3.10 'distutils' is deprecated with removal slated for Python | ||
7 | 3.12. Switch from 'distutils.core' to 'setuptools'. | ||
8 | |||
9 | This also allows for a 'wheel' binary archive format to be built with | ||
10 | 'setup.py bdist_wheel'. | ||
11 | |||
12 | Upstream-Status: Submitted | ||
13 | [https://github.com/rhinstaller/python-meh/pull/37] | ||
14 | |||
15 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
16 | |||
17 | --- | ||
18 | setup.py | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/setup.py b/setup.py | ||
22 | index 9c12180..3ba5195 100644 | ||
23 | --- a/setup.py | ||
24 | +++ b/setup.py | ||
25 | @@ -1,6 +1,6 @@ | ||
26 | #!/usr/bin/python3 | ||
27 | |||
28 | -from distutils.core import setup | ||
29 | +from setuptools import setup | ||
30 | |||
31 | setup(name='python-meh', version='0.50.1', | ||
32 | description='Python module for handling exceptions', | ||