diff options
author | wangmy <wangmy@fujitsu.com> | 2022-04-02 20:32:47 +0800 |
---|---|---|
committer | Trevor Gamblin <trevor.gamblin@windriver.com> | 2022-04-06 14:55:16 -0400 |
commit | db5534e5316697dda0529d58c1531b8201622bc1 (patch) | |
tree | 894946fe3944e9a14364d75dd7d383b9fd15287c /meta-python/recipes-extended/python-pyparted/files/setuptools.patch | |
parent | 166cfe0ae2aa2eadbaaadb391993ed9aecb972c1 (diff) | |
download | meta-openembedded-db5534e5316697dda0529d58c1531b8201622bc1.tar.gz |
python3-pyparted: upgrade 3.11.7 -> 3.12.0
setuptools.patch removed since it's included in 3.12.0
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/files/setuptools.patch')
-rw-r--r-- | meta-python/recipes-extended/python-pyparted/files/setuptools.patch | 82 |
1 files changed, 0 insertions, 82 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/files/setuptools.patch b/meta-python/recipes-extended/python-pyparted/files/setuptools.patch deleted file mode 100644 index 51fe8c7c56..0000000000 --- a/meta-python/recipes-extended/python-pyparted/files/setuptools.patch +++ /dev/null | |||
@@ -1,82 +0,0 @@ | |||
1 | Upstream-Status: Submitted [https://github.com/dcantrell/pyparted/pull/85] | ||
2 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
3 | |||
4 | From 3f5ca7eb6f57d8bcaa3b333497aba6e53d847450 Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@arm.com> | ||
6 | Date: Fri, 14 Jan 2022 16:06:31 +0000 | ||
7 | Subject: [PATCH] setup.py: port to setuptools | ||
8 | |||
9 | Python 3.10 has deprecated distutils[1], and it will be removed entirely | ||
10 | in Python 3.12. | ||
11 | |||
12 | As the setuptools API is identical, moving to setuptools is trivial by | ||
13 | changing the import. | ||
14 | |||
15 | Remove check_mod_version, a version specifier can be passed directly | ||
16 | to pkg-config. | ||
17 | |||
18 | Remove unused imports. | ||
19 | |||
20 | [1] https://docs.python.org/3/whatsnew/3.10.html#distutils-deprecated | ||
21 | |||
22 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
23 | --- | ||
24 | setup.py | 29 +++++++++-------------------- | ||
25 | 1 file changed, 9 insertions(+), 20 deletions(-) | ||
26 | |||
27 | diff --git a/setup.py b/setup.py | ||
28 | index da71d9c..1e9e367 100644 | ||
29 | --- a/setup.py | ||
30 | +++ b/setup.py | ||
31 | @@ -25,12 +25,7 @@ import glob | ||
32 | import os | ||
33 | import platform | ||
34 | import sys | ||
35 | -from distutils.ccompiler import new_compiler | ||
36 | -from distutils.errors import CompileError | ||
37 | -from distutils.errors import LinkError | ||
38 | -from distutils.core import setup | ||
39 | -from distutils.core import Extension | ||
40 | -from distutils.version import LooseVersion | ||
41 | +from setuptools import setup, Extension | ||
42 | |||
43 | pyparted_version = '3.11.7' | ||
44 | python_version = sys.version_info | ||
45 | @@ -45,19 +40,13 @@ if python_version < need_python_version: | ||
46 | # http://code.activestate.com/recipes/502261-python-distutils-pkg-config/ | ||
47 | def pkgconfig(*packages, **kwargs): | ||
48 | flag_map = {'-I': 'include_dirs', '-L': 'library_dirs', '-l': 'libraries'} | ||
49 | - for token in subprocess.check_output(["pkg-config", "--libs", "--cflags"] + list(packages)).decode('utf-8').split(): | ||
50 | - | ||
51 | - kwargs.setdefault(flag_map.get(token[:2]), []).append(token[2:]) | ||
52 | - return kwargs | ||
53 | - | ||
54 | -def check_mod_version(module, version): | ||
55 | - modversion = subprocess.check_output(["pkg-config", "--modversion", module]).decode('utf-8').split()[0] | ||
56 | - if not LooseVersion(modversion) >= LooseVersion(version): | ||
57 | - sys.stderr.write("*** Minimum required %s version: %s, found: %s\n" % (module, version, modversion,)) | ||
58 | - sys.exit(1) | ||
59 | - return | ||
60 | - | ||
61 | -check_mod_version('libparted', need_libparted_version) | ||
62 | + try: | ||
63 | + for token in subprocess.check_output(["pkg-config", "--libs", "--cflags"] + list(packages), | ||
64 | + universal_newlines=True).split(): | ||
65 | + kwargs.setdefault(flag_map.get(token[:2]), []).append(token[2:]) | ||
66 | + return kwargs | ||
67 | + except subprocess.CalledProcessError as e: | ||
68 | + sys.exit("Cannot find pkg-config dependencies:\n" + e.output) | ||
69 | |||
70 | # This list is in the format necessary for the define_macros parameter | ||
71 | # for an Extension() module definition. See: | ||
72 | @@ -77,6 +66,6 @@ setup(name='pyparted', | ||
73 | ext_modules=[Extension('_ped', | ||
74 | sorted(glob.glob(os.path.join('src', '*.c'))), | ||
75 | define_macros=features, | ||
76 | - **pkgconfig('libparted', | ||
77 | + **pkgconfig('libparted >= %s' % need_libparted_version, | ||
78 | include_dirs=['include'])) | ||
79 | ]) | ||
80 | -- | ||
81 | 2.25.1 | ||
82 | |||