diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-05-26 03:37:30 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-05 11:01:47 +0200 |
commit | abc5a71c4d216742dc2af4b475136262ac169612 (patch) | |
tree | 2f5c60e63f45ffc89332034d5f15f946482fd94d /meta-python/recipes-extended/python-pyparted/python-pyparted.inc | |
parent | 0cf7b58745b1bc28d3affef49d5b56128287a576 (diff) | |
download | meta-openembedded-abc5a71c4d216742dc2af4b475136262ac169612.tar.gz |
python3-pyparted: add a python3 recipe
- Split to a common python-pyparted.inc for python2 and python3
- Tweak 0001-fix-version-float-check.patch for python3 to fix
do_compile errror
----
| ERROR: python3 setup.py build_ext execution failed.
| Traceback (most recent call last):
| File "setup.py", line 62, in <module>
| check_mod_version('libparted', need_libparted_version)
| File "setup.py", line 55, in check_mod_version
| match = re.search('([0-9]+\.[0-9]+)', modversion)
| File "work/core2-64-wrs-linux/python3-pyparted/3.10.7+gitAU
TOINC+69c4a478e4-r0/recipe-sysroot-native/usr/lib/python3.5/re.py",
line 173, in search
| return _compile(pattern, flags).search(string)
| TypeError: cannot use a string pattern on a bytes-like object
----
The reason is the return of subprocess.check_output is byte in python3,
but string in python2
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python-pyparted.inc')
-rw-r--r-- | meta-python/recipes-extended/python-pyparted/python-pyparted.inc | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc new file mode 100644 index 0000000000..65f8ca14db --- /dev/null +++ b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \ | ||
2 | an interface to libparted, the GNU parted library for disk partitioning and \ | ||
3 | filesystem manipulation." | ||
4 | SUMMARY = "Python bindings for libparted" | ||
5 | HOMEPAGE = "https://github.com/rhinstaller/pyparted" | ||
6 | LICENSE = "GPL-2.0+" | ||
7 | LIC_FILES_CHKSUM = "\ | ||
8 | file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \ | ||
9 | file://src/_pedmodule.c;startline=10;endline=22;md5=ebcb25dde1ac9c46e986dec79b404e7e \ | ||
10 | " | ||
11 | DEPENDS += "parted" | ||
12 | |||
13 | # upstream only publishes releases in github archives which are discouraged | ||
14 | SRCREV = "69c4a478e43d3eff6ae3a0116fa38da06776d5f5" | ||
15 | SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https \ | ||
16 | file://0001-fix-version-float-check.patch \ | ||
17 | " | ||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | RDEPENDS_${PN} += "parted (>= 2.3)" | ||
21 | RDEPENDS_${PN}_class-native = "" | ||