summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commita6d7ba92645a112af358efd94ff3aa0c74985a51 (patch)
tree6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb
parented634d36d64af846b68424d38eaa86b464584840 (diff)
downloadmeta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb')
-rw-r--r--meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb b/meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb
new file mode 100644
index 0000000000..120a8a7927
--- /dev/null
+++ b/meta-python/recipes-python/python/python-cloudeebus_0.6.0.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "A component which enables calling DBus methods and registering on DBus signals from Javascript"
2HOMEPAGE = "https://github.com/01org/cloudeebus"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
6
7SRC_URI = "git://github.com/01org/cloudeebus.git;protocol=http;branch=master "
8SRCREV = "b5cc957eeabfe98cb996baf8e5a0ac848993c3d4"
9
10S = "${WORKDIR}/git"
11
12inherit distutils
13
14DEPENDS_${PN} = "python python-distribute"
15RDEPENDS_${PN} = "python python-dbus python-json python-argparse python-pygobject python-autobahn python-twisted python-subprocess"
16
17do_install_prepend() {
18 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}
19}
20
21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --single-version-externally-managed \
23 --prefix=${prefix} \
24 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
25 --install-data=${datadir}"
26
27do_install_append() {
28 distutils_do_install
29 install -d ${D}${datadir}/doc/${BPN}/
30 install -m 0644 ${S}/README.md ${D}${datadir}/doc/${BPN}/
31}
32
33FILES_${PN} += "${datadir}/cloudeebus"
34FILES_${PN} += "${sysconfdir}/dbus-1/system.d/org.cloudeebus.conf"
35