diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-15 16:32:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:49 +0200 |
commit | a6d7ba92645a112af358efd94ff3aa0c74985a51 (patch) | |
tree | 6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-gevent_0.13.8.bb | |
parent | ed634d36d64af846b68424d38eaa86b464584840 (diff) | |
download | meta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz |
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not
depended upon by recipes already in meta-oe (e.g. gateone,
anki)
* Recipes NOT moved:
python-futures
python-pyopenssl
python-simplejson
python-tornado
python-pyqt
python-sip
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-gevent_0.13.8.bb')
-rw-r--r-- | meta-python/recipes-python/python/python-gevent_0.13.8.bb | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-gevent_0.13.8.bb b/meta-python/recipes-python/python/python-gevent_0.13.8.bb new file mode 100644 index 0000000000..3fd3e7c536 --- /dev/null +++ b/meta-python/recipes-python/python/python-gevent_0.13.8.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "A coroutine-based Python networking library" | ||
2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ | ||
3 | a high-level synchronous API on top of the libevent event loop." | ||
4 | HOMEPAGE = "http://www.gevent.org" | ||
5 | SECTION = "devel/python" | ||
6 | LICENSE = "MIT & BSD" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2 \ | ||
8 | file://LICENSE.pyevent;md5=718070c63de243053e2c616268b00fdd" | ||
9 | DEPENDS += "python-greenlet libevent" | ||
10 | RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" | ||
11 | |||
12 | SRC_URI = "http://pypi.python.org/packages/source/g/gevent/gevent-${PV}.tar.gz" | ||
13 | SRC_URI[md5sum] = "ca9dcaa7880762d8ebbc266b11252960" | ||
14 | SRC_URI[sha256sum] = "54b8d26300ce408c0916a3e63ef6cd3e6aca76230833558deb7de15196ed955e" | ||
15 | |||
16 | S = "${WORKDIR}/gevent-${PV}" | ||
17 | |||
18 | inherit setuptools | ||
19 | |||