diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-15 16:32:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:49 +0200 |
commit | a6d7ba92645a112af358efd94ff3aa0c74985a51 (patch) | |
tree | 6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-lxml_3.0.2.bb | |
parent | ed634d36d64af846b68424d38eaa86b464584840 (diff) | |
download | meta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz |
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not
depended upon by recipes already in meta-oe (e.g. gateone,
anki)
* Recipes NOT moved:
python-futures
python-pyopenssl
python-simplejson
python-tornado
python-pyqt
python-sip
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-lxml_3.0.2.bb')
-rw-r--r-- | meta-python/recipes-python/python/python-lxml_3.0.2.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-lxml_3.0.2.bb b/meta-python/recipes-python/python/python-lxml_3.0.2.bb new file mode 100644 index 0000000000..5ab7b4a793 --- /dev/null +++ b/meta-python/recipes-python/python/python-lxml_3.0.2.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "Python XML bindings for libxml2 and libxslt" | ||
2 | DESCRIPTION = "Powerful and Pythonic XML processing library combining \ | ||
3 | libxml2/libxslt with the ElementTree API." | ||
4 | HOMEPAGE = "http://codespeak.net/lxml" | ||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b" | ||
7 | SRCNAME = "lxml" | ||
8 | |||
9 | DEPENDS = "libxml2 libxslt" | ||
10 | |||
11 | SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml" | ||
12 | SRC_URI[lxml.md5sum] = "38b15b0dd5e9292cf98be800e84a3ce4" | ||
13 | SRC_URI[lxml.sha256sum] = "cadba4cf0e235127795f76a6f7092cb035da23a6e9ec4c93f8af43a6784cd101" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
16 | |||
17 | inherit setuptools | ||
18 | |||
19 | DISTUTILS_BUILD_ARGS += " \ | ||
20 | --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \ | ||
21 | --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \ | ||
22 | " | ||
23 | |||
24 | DISTUTILS_INSTALL_ARGS += " \ | ||
25 | --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \ | ||
26 | --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \ | ||
27 | " | ||
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||
30 | |||
31 | RDEPENDS_${PN} += "libxml2 libxslt python-compression" | ||
32 | RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native" | ||
33 | |||