summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-lxml_3.0.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitd22f4ca2e3e421615b601002061690a8f97257c0 (patch)
tree8cfee5bd859365868dc3cb5eb9ba91d9713efb79 /meta-python/recipes-python/python/python-lxml_3.0.2.bb
parent2d7c7956bd3655755e1e800b7b05732f0c1a3786 (diff)
downloadmeta-openembedded-d22f4ca2e3e421615b601002061690a8f97257c0.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-lxml_3.0.2.bb')
-rw-r--r--meta-python/recipes-python/python/python-lxml_3.0.2.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-python/python/python-lxml_3.0.2.bb b/meta-python/recipes-python/python/python-lxml_3.0.2.bb
deleted file mode 100644
index 5ab7b4a793..0000000000
--- a/meta-python/recipes-python/python/python-lxml_3.0.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "Python XML bindings for libxml2 and libxslt"
2DESCRIPTION = "Powerful and Pythonic XML processing library combining \
3libxml2/libxslt with the ElementTree API."
4HOMEPAGE = "http://codespeak.net/lxml"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
7SRCNAME = "lxml"
8
9DEPENDS = "libxml2 libxslt"
10
11SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
12SRC_URI[lxml.md5sum] = "38b15b0dd5e9292cf98be800e84a3ce4"
13SRC_URI[lxml.sha256sum] = "cadba4cf0e235127795f76a6f7092cb035da23a6e9ec4c93f8af43a6784cd101"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DISTUTILS_BUILD_ARGS += " \
20 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
21 --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
22"
23
24DISTUTILS_INSTALL_ARGS += " \
25 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
26 --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
27"
28
29BBCLASSEXTEND = "native nativesdk"
30
31RDEPENDS_${PN} += "libxml2 libxslt python-compression"
32RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
33