summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-m2crypto
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commita6d7ba92645a112af358efd94ff3aa0c74985a51 (patch)
tree6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-m2crypto
parented634d36d64af846b68424d38eaa86b464584840 (diff)
downloadmeta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-m2crypto')
-rw-r--r--meta-python/recipes-python/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-python/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
new file mode 100644
index 0000000000..bcbdf24bb5
--- /dev/null
+++ b/meta-python/recipes-python/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -0,0 +1,39 @@
1From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 29 Mar 2013 15:17:17 +0100
4Subject: [PATCH] setup.py: link in sysroot, not in host directories
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-status: Unknown
9---
10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-)
12
13diff --git a/setup.py b/setup.py
14index e7c49eb..8deaa34 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
18 self.openssl = 'c:\\pkg'
19 else:
20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr'
22+ self.openssl = os.environ.get( "STAGING_DIR" )
23
24
25 def finalize_options(self):
26@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
27
28 build_ext.build_ext.finalize_options(self)
29
30- opensslIncludeDir = os.path.join(self.openssl, 'include')
31- opensslLibraryDir = os.path.join(self.openssl, 'lib')
32+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
33+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
34
35 self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
36 [opensslIncludeDir]]
37--
381.8.1.4
39